Ford Owners Club - Ford Forums Messages

Club Announcements

Ford Fair 2016: Tickets and stand passes are now available to purchase. More info here.

Review your Ford: Help others when it comes to buying a car like yours and review your Ford now

Ford Car Parts: View All ford car parts by category. Look for Ford Car Parts now!

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


sype

Budding Enthusiast
  • Content count

    2
  • Joined

  • Last visited

About sype

  • Rank
    Newbie

Profile Information

  • Ford Model
    Fiesta 1.4 Durashift
  1. I had to take it into the garage in the end, they said it was the Automator that had gone wrong, it was quite an expensive repair, something around £600.
  2. Don't know if anyone can advise with this problem. Recently my 2003 1.4 Durashift Fiesta has been giving me a few problems. Whilst driving, usually either when accelerating fairly heavily or slowing down at junctions the car will lose drive. It feels like the car has gone in to neutral - the engine will still rev but there is complete loss of drive. The display still shows the car as being in gear but it won't move forward. When this happens an amber warning light with an exclamation mark in a gear shape lights up (the handbook describes this as Durashift EST warning light) This happened a few times before christmas and usually turning the engine off and restarting would fix it, but last week when this happened even after restarting the engine the car would go in to neutral and not allow me to select any gear - even reverse. it was only after many attempts to get the car moving again that it finally got into gear. I'm going to have it looked at this week but I was just wondering if anyone else had run into this problem or had any ideas on the possible cause of the problem.