AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


londonarsenal

Budding Enthusiast
  • Content count

    4
  • Joined

  • Last visited

About londonarsenal

  • Rank
    Newbie

Profile Information

  • Gender* Male
  • Ford Model Focus Zetec S 2008
  • UK/Ireland Location Kent
  • Annual Mileage 0 to 5000
  1. Lighting Issues With Dipped Beam...help!

    Many thanks for your advice.
  2. Lighting Issues With Dipped Beam...help!

    Thanks for your prompt reply. In that case should there be a lever on the light fitting which i can adjust so they both shine at the same level?
  3. Hi all, a quick question if you could be so kind to help. I have a mk2.5 Focus Zetec S and recently I changed the factory fitted bulbs in the headlamp (side lights, dipped and main beam) to bright white/hint of blue xenon bulbs. The side lights look great as you can see from the photo, as too do the main beams. My concern is with the dipped beam...when the dipped beam is on, it is very noticeable from not too much of a distance away that the driver side lamp is brighter and more "white" than the passenger side. I went back to the shop where I purchased the bulbs from and the fella who worked there said to me that the driver's side beam will inevitably be brighter as the bulb is pointing straight on to help with driver visibility and the passenger side beam is pointing down towards the road to light the road ahead and make it clearer. Now I have no idea whether this is true or not, I am leaning towards that it isn't!...I don't really know what I need to do here, so please if you Focus gurus could shed some light on this...excuse the pun! Any help would be greatly appreciated. 1st photo: side lights only 2nd photo: side lights and full beam 3rd photo: side lights and DIPPED BEAM
  4. Hi all, long time voyeur, but first time poster. I have a little problem which I would appreciate some help with. I have a 2008 Focus Zetec S, and yesterday when I filled the car up with petrol (£15 only), the needle for the petrol rose to where it should as per normal (car was running on empty), but as you will see in the attached photo, the digital display which indicates how many miles I can drive with the remaining petrol in the tank is on zero. I thought maybe this is just a "bug" with the car and decieed to park the car up and check this morning/evening, but again same issue. The digital display still reads I can drive "0 mls" only! What could this be guys? Please also note that all the other functions; mpg, etc work perfectly fine. Any assistance would be much appreciated. Thank you. :)