Budding Enthusiast
  • Content count

  • Joined

  • Last visited

About Reecy

  • Rank

Profile Information

  • Gender*
  • Ford Model
    MK3 Mondeo Estate 2.0 TDCI
  • Ford Year
  • UK/Ireland Location
  • Annual Mileage
    0 to 5000
  • Interests
    Classic Cars
    General Automotive
    Food & Drink
    Computers & Electronics

Recent Profile Visitors

862 profile views
  1. hi, did you ever get to the bottom of your limp mode issue, i have the same i think p0235 code? turbo is ok but no boost, map sensor is clean, egr valve is clean?


  2. Had the same myself it ended up being the diesel pump in the end after changing allsorts of things car runs perfect now although with all the smoke i would defo check the boost pipe first
  3. thanks a lot mate only just got the last post im gonna get it all changed asap :-) turbo / manifold the lot cheers craig
  4. had the egr valve blanked off already mate didnt make a blind bit of difference and its the catridge thats been replaced not the manifold also there was quite a bit of carbon on the old one thats been taken out.... Anymore suggestions ? i didnt think it was the turbo myself as everything was pressurising properly eg the boost pipes from egr to intercooler but i was assured it was the turbo its like the engines being starved to me i reckon its a !Removed! sensor but ive had that replaced too gonna have to send it in to fords for them to tell me they dont know whats up with it :-(
  5. right guys just had a new turbo fitted and theres no change whatsoever !!!! plenty boost in the system but no power !!! im getting really peed off with this !Removed! car....
  6. yes mate its at the front of the inlet manifold theres two of them with 3 pipes coming off em, also the actuators moving the arm when i start it up also you can hear the turbo kicking when revving and the boost pipe extracts there are no blockages anywhere had all pipes off one by one and checked em out also the intercooler..... foca said it could be the variable vanes in the turbo as everything elso seems to be working but iam still getting fault code p0235 on FSuper im sure its the turbo but could it be a sensor somewhere ie cam/crank as the fault started intermittent at first ???
  7. cheers for that mate mines the pnuematic actuator variable vane type so looks like its gonna be a new turbo :-( gonna have to get it fixed tho as its shockingly slow until it warms up and its not much better when its warm ..
  8. all the clocks are now back on and working fine but theres still no power there atall im thinking its defo the turbo !!! :-(
  9. mate ive cleaned everything that i could clean !!!! another mechanics said its the turbo but there would be no boost atall wouldnt there and the pipes wouldnt fill up when revving up !!! im snookered !!
  10. hi guys hope you can help me with this one as im going bald with the problems !! Started off with an intermittent fault with the turbo not working would work if u turned ignition off and on again but would just stop working while i was driving especially when i came to a set of lights, thought it would of been a split in one of the boost pipes but checked them all, cleaned the egr valve Problem still happening, Bought Ford F-Super comes up with fault P0235 so replaced the map sensor on the lower egr pipe with genuine ford one still no change Had the turbo checked out no play in it and air is flowing through all pipes are boosting theres no blockages in any pipes or the intercooler atall Im really at my witts end with this car and now the clocks have started going bonkers and resetting themselves every now and then and sometimes wont come on atall with just the oil light and washer bottle working its doing my nut in its like they have all happened at once !!! Any help would be muchly appreciated, ps the car does drive and dont think its in limp home mode can get 70 on the motorway but it takes an age to get there and if theres an uphill then its drop a gear at a time til u reach the top !!! Any suggestions muchly appreciated cheers guys Reecy
  11. Welcome to the Ford forums Reecy :)

    1. Reecy


      Thanks mate !