Ford Owners Club - Ford Forums Messages

Club Announcements

Discounted Car Insurance: Owners Club insurance could save you money on your car insurance. Get a quote

Review your Ford: Help others when it comes to buying a car like yours and review your Ford now

Ford Car Parts: View All ford car parts by category. Look for Ford Car Parts now!

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


Dychie

New Member
  • Content count

    1
  • Joined

  • Last visited

About Dychie

  • Rank
    Newbie
  • Birthday 02/04/1973

Profile Information

  • Gender*
    Male
  • Ford Model
    Focus C-Max 2.0tdci
  • Ford Year
    2005
  • UK/Ireland Location
    Denbighshire
  • Annual Mileage
    10,001 to 15,000
  • Interests
    Classic Cars
    General Automotive
    Motorsport & Racing
    Car Restoration
    Car Modification
  1. Happy Birthday Dychie!

  2. Hi all, New to the forum and to fords in general my last ford was a mk5 escort cabriolet. I purchased a top spec ghia C-max 2.0tdci 2005 a few weeks ago and experiencing so running issues car starts and runs fine at tickover hot and cold its only when revved above a 1000rpm it sounds like its missing running on three cylinders. There is no smoke, power seems 100% with masses of torque even on full boost it feels like its on three cylinders lumpy, fuel economy normal. Any ideas, i suspect, egr, fuel injector, or clutch, or a combination of all three. No warning lights on. HELP HELP.
  3. Welcome to the Ford forums Dychie :)