AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


allyharvell

Budding Enthusiast
  • Content count

    6
  • Joined

  • Last visited

About allyharvell

  • Rank
    Newbie

Profile Information

  • Ford Model
    16v 1.6 escort si 1997
  1. sorry forgot to say i can get the gearbox for the new engine and also mine is a dohc engine im not sure if the 2000 model is or not thanks
  2. Any ideas if the 2000 engine put in escorts is the same as 1997 escort engine? I think they only go from 1995 to 1999 but then the other half of me thinks it goes from 1995 to 2000, any ideas? I have a 1600 16v 1997 escort si and the new engine will be from a 1600 16v escort (i dont know the trim on the car). my starter is at the rear on mine but dont know if the 2000 is at the rear or the front, any ideas? thanks all
  3. ok its not noisy now, blown a nice hole in the block so a def new engine needed :o Any ideas where is cheap?
  4. Hi, just bought this car and was told cam shaft had gone when we got it but it doesnt sound to us like it has, at first we thought it was the cam followers but now having had it running today for a little longer it sounds as though it could be the hydraulic lifters/tappets - whatever you want to call them! What do you lot think I have a video of the noise on you tube here......... http://uk.youtube.com/watch?v=l3C5vkxkutk&...re=channel_page It starts as soon as you start the engine but when you get to around 4000 rpm it seems to go and then as soon as you drop the rpm back it starts again. As its on my drive and is so noisy and loud we havent dared have it run for too long, just in case the neighbours create about the racket, however it was towed back (running on tick over all the way) for 50 miles (not revving obviously) and it did it all the way home so it has been running for a little while but just no rpm when it was being towed. What do you think the problem could be? Thanks
  5. posted this topic http://www.fordownersclub.com/forums/index...?showtopic=3136 a couple days ago but ended up no closer to solving the problem so as I think I know what it is then it will be just as easy to put a new engine in anyone know where has any at the moment I really just want a straight swap same car for same car rather than make any mdifications to get a slightly different engine in its a petrol car anyway the other details of it are in the title, so do you know anywhere that sells engines for best price possible, obviously the cheaper the better but i certainly dont wanna buy any junk or anything that doesnt work or I'll be no further forward than I am now lol so please if u know anywhere then please do share so I can get this noisy heap transformed and on the road Thank you all
  6. Hi, just bought this car and was told cam shaft had gone when we got it but it doesnt sound to us like it has, at first we thought it was the cam followers but now having had it running today for a little longer it sounds as though it could be the hydraulic lifters/tappets - whatever you want to call them! What do you lot think I have a video of the noise on you tube here......... http://uk.youtube.com/watch?v=l3C5vkxkutk&...re=channel_page It starts as soon as you start the engine but when you get to around 4000 rpm it seems to go and then as soon as you drop the rpm back it starts again. As its on my drive and is so noisy and loud we havent dared have it run for too long, just in case the neighbours create about the racket, however it was towed back (running on tick over all the way) for 50 miles (not revving obviously) and it did it all the way home so it has been running for a little while but just no rpm when it was being towed. What do you think the problem could be? Thanks