• Announcements

    • Stoney871

      Posting in General Chat thread.   11/11/2017

      it has been noted that too many Members are posting messages in the General Chat area instead of the correct Forums. Any messages posted in the General Chat area that are not General Chat will be deleted without warning and offenders may recieve warning points if repeated instances are seen from that Member. There are plenty of different Club areas that encompass 99% of Ford related posts, please select and use the correct one. If anyone is not sure of which area to post something then feel free to P/M myself or other Senior Staff for guidance. The Moderating Staff are having to spend far too much time chasing this problem instead of maintaining the other areas of the forum.


Mogz88

Budding Enthusiast
  • Content count

    2
  • Joined

  • Last visited

About Mogz88

  • Rank
    Newbie

Profile Information

  • Ford Model
    Fiesta Mk 7 1.4 TITANIUM
  • UK/Ireland Location
    Greater London
  1. Hi Guys, i recently installed a HID Kit on my 2009 Fiesta 1.4 TITANIUM to replace my normal H7 Halogen bulbs to 6000k Xenon's it was okay for a while but then i noticed that sometimes the HID's don't start up properly, they turn on for a split second and then they go off again, just wanted to see if any one else has experienced anything like this or if any one knows what this could be??? Cant be having light issues on these dark nights!!! Don't want to give the old bill a reason to pull me over either!!! NEED TO SORT IT!!! :-) Thanks in advance, i look forward to the feed back...
  2. Welcome to the Ford forums Mogz88 :)