Ford Owners Club - Ford Forums Messages

Club Announcements

Ford Fair 2016: Tickets and stand passes are now available to purchase. More info here.

Review your Ford: Help others when it comes to buying a car like yours and review your Ford now

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


Kevinlfc17

Budding Enthusiast
  • Content count

    20
  • Joined

  • Last visited

About Kevinlfc17

  • Rank
    Member

Profile Information

  • Ford Model Zetec s 2.5 v6
  • UK/Ireland Location Lancashire
  1. Xenon Bulbs

    Hi I have an 03 st 170 can any one tell we're I can get xenon bulbs from my car has the factory xenon headlight fitted
  2. Door Handle

    Hi can any one help st170 drive door handle outside u have to pull the handle dead quick to open and some times it won't open what could the problem be
  3. Clonking Sound

    Thanks going on a ramp 2moro to have a look
  4. Clonking Sound

    I was thinking that but it only does it in reverse normally a cv joint clunks when u go round bends but I will get it checked out thanks
  5. Clonking Sound

    Hi I have a 2003 2.5V6 mondeo what it is I get what it sounds like a clonking sound on a lock and only in reverse any ideas thanks
  6. Tyre Help

    Thanks for that I had 28psi try 32 c if that make any difference
  7. Tyre Help

    Hi I have a 2003 2.5v6 mondeo with 225/40/18 tyres can any one tell me what the right tyre pressure is as the middle of the tyre is wearing more I have been told it could be the tyre pressure
  8. Esp Switch

    It is the facelift one it's only small things like the heated screen switches alarm sensors it's more electric stuff than any think I don't understand why the older model has the esp button and the later model does not u get a but better performance with it switch off I had the facelift fiesta zetec s and that did not have a ESP switch on it but the older model did I have taken the boot release button out and there is only one plug there less that does both switches
  9. Zetec S Alloys

    Hi does any one no of any were in Liverpool I can get my wheels powder coated some place won't touch them as they r diamond cut alloys thanks
  10. Esp Switch

    Hi I have a late 2003 mondeo 2.5v6 zetec s I don't have a ESP switch when I have looked at early models they have one my car seems to have a lot of stuff of the mark 4mondeo on it does any one no if the wiring loom for the switch is there behind the blank cover next to the boot release switch thanks
  11. Starting Problems

    Mine is like that flat roads with no ruts in it and its fine I had a 525 MSPORT before the mondeo that had 17inch alloys on it with 225/4017 on it that done the same it must just be the low profile of the tyre it's hard to find flat roads in England now thanks for your help
  12. Starting Problems

    Thanks for that I will change that this week c how its goes c if you could help me with another problem when I am going down the road and I am in what I can only think r ruts from we're wagons are up and down all the time the car seems to be all over the place I have been told it could be the size of the tyres it's got 225/40/18 on it the standard zetec s alloys cause I have got no knocks or bangs from it the only thing now and again when in revers on full lock I get what u would say click or a little bang
  13. Mk3 Mondeo Running Issue

    Hi I had the same problem as you changed all the normall stuff it turned out I had two bent valves number 2&3 just check the manifold not been changed that is a sigh so some one can sell the car quick hope u resolve your problem soon and it's not the valves
  14. Starting Problems

    HI I HAVE A 2003 2.5 V6 MONDEO WHEN I START THE CAR IT WON'T FIRE UP ON THE FIRST CRANK OF THE KEY SOME TIMES IT TAKES 3CRANKS TO START ONCE RUNNING ITS FINE RUNS SMOOTH NO MISFIRES I HAVE CHANGE THE PLUGS NEW AIR FILTER I HAVE HAD IT ON A COMPUTER NO FAULTS AT ALL THE GUY DONE A INDEPTH ONE THE ONLY THING I HAVE NOT CHANGE IS THE FUEL FILTER COULD THAT CAUSE IT I HAVE ALSO BEEN TOLD TO RUN IT ON THE BETTER UNLEAD FUEL NOT THE NORMALL ONE IS THAT TRUE AND WILL IT MAKE A DIFFERENCE THANKS
  15. Starting Problem

    No it's happened a few times it only does it when the fuel is low I am now thinking it could be the petrol filter as that is the only thing I not changed I have had it on the computer and there is no other faults