Ford Owners Club - Ford Forums Messages

Club Announcements

Ford Fair 2016: Tickets and stand passes are now available to purchase. More info here.

Review your Ford: Help others when it comes to buying a car like yours and review your Ford now

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


Richbaker22

Budding Enthusiast
  • Content count

    49
  • Joined

  • Last visited

About Richbaker22

  • Rank
    Settling In Well

Profile Information

  • Ford Model Mk6 fiesta
  • UK/Ireland Location Devon

Recent Profile Visitors

959 profile views
  1. Help please Long story short... I snapped a glowplug in the engine trying to remove it I have now got the best part of it out by using a locksmiths centering sleeve and drilling it then using a bolt extractor with a backwards thread to unscrew the glowplug from the head, my problem now it that the tip or the electrode it still in there. I have tried long magnets and starting the engine to blow it out with the compression neither has worked I have read that removing the injector and trying to get it from there is a good idea but I cannot find any guides on how to remove the injector, I tried to remove it today only to fail and put it all back together. Any help appreciated. Thanks
  2. Im guessing you had to remove the fuel pump to get the EGR off as I did when I blanked mine, are you sure you plugged it back in when you re fitted it?
  3. 2005 1.6TDCI injector removal/re-sealing

    Any news on how to remove this injector? I cannot get the plastic bit off that the electronic plug goes in! I have a snapped glowplug tip in the engine and am hoping to fish it out by removing the injector
  4. I'm also attempting to try this! I have been reading also and have read that the 12v socket switches off after 10mins to half an hour after the car has been locked and then becomes active again once the doors are unlocked, it could be worth checking this as this could be useful for the dashcam if this is the case, for example when you park up at tescos and go shopping it will still record for 10 mins (in case someone reverses into your car)
  5. Ford Focus (2006) 1.8 Tdci - Limp Mode

    Be careful removing them I attempted to do my glowplugs today and the first one snapped its half threaded and the top has snapped off, by the looks of things I have myself a nightmare!
  6. 12V Ignition Cable?

    Soooo I put this job off until the piggy back fuse arrives and I decided to get the other jobs done today, I blanked off the egr will little to no problems.... Then decided to change the glow plugs 😭 long story short the first one snapped off, it's half threaded half not and the top has broke off :( any tips for removing this? From searching YouTube ect it looks like you need some specialist tools, should I make a new thread?
  7. 12V Ignition Cable?

    I'm after a ignition only supply I may have to put this off and get a piggyback fuse by the sounds of it. Thanks
  8. 12V Ignition Cable?

    I'm in a focus mk2 55reg 1.6tdci I probably should of added that at the beginning 😀
  9. 12V Ignition Cable?

    I will look into that now, Thanks, but ideally i would like to do it with what I have if its possible as I want to get it done today because I need to do a lot of jobs on the car this week as I have just bought it, it has engine management light and a red cog keep popping up on dash putting it into limp mode I have scanned it and it's coming up with glow plugs and egr valve so tomorrow's job is clean pipes and blank off egr, change glow plugs and add the diesel fuel additive to clean the system and injectors, I also have a rear parking sensor kit on order so I'll try that in the next few days so no doubt you will see a few more posts from me this week looking for some pointers 😉
  10. 12V Ignition Cable?

    I'm looking to make a hidden 12v ignition live plug socket for my dashcam I have purchased this... http://pages.ebay.com/link/?nav=item.view&alt=web&id=371330753374 And cut the plug off, I also have some scotch locks to tap into a wire, I also unscrewed the plug I already cut off and it has a fuse in it! Is this a problem? Because I assume the wire I'm tapping into is fused so it won't matter. Any help appreciated I have tried to tap the yellow/green wire going into the fuse box under the passenger footwell with no luck. Thanks
  11. Mk6 Fiesta Remote Central Locking

    I'll just check for a thread on here I'm sure I put a photo on of my wires but I have no idea where sorry I can't rember much about it other than it was s job that was really annoying! Lol
  12. Mk6 Fiesta Remote Central Locking

    Hi mate wow this thread brings back memories... Iv had a 2 mgzrs 2golfs a Laguna and my current BMW since I had this fiesta, you need to go for the grey plug that has the 2 blue indicator wires in it, one may be blue and red... I think? Let me know how it goes :)
  13. Help Please Poss Immobiliser Problem?

    Please help :) So far I have had it plugged in coming up flash code 16 can anyone tell me what this is? Have checked fuses Have disconnected the ecu Have disconnected the battery Have removed the dials Still same problem
  14. Help Please Poss Immobiliser Problem?

    Bump
  15. Mk6 Fiesta 1.25 petrol 2004 So I was driving along then all of a sudden every warning lights come up on the dash including the immobiliser light wich is flashing fast. So I pull over and pop the bonnet everything seems ok water oil ect, Then I get back in and try to start the car and it won't start it also won't bump start or jump Start all the warning lights are still on . I have checked all the fuses and have tried to disconnect the battery for 20mins then reconnect put in radio code and still all tge warning lights are on and it won't start. I have found a way to bypass it and get it started by pulling out the bottom relay under the glove box and plugging it back in fast whilst holding the key in the start position , this allows me to start and drive the car but with no speedo , no Rev counter and all the lights flashing this will do me for today but I need to find out the problem ASAP Any help appreciated Thanks