• Announcements

    • Stoney871

      Posting in General Chat thread.   11/11/2017

      it has been noted that too many Members are posting messages in the General Chat area instead of the correct Forums. Any messages posted in the General Chat area that are not General Chat will be deleted without warning and offenders may recieve warning points if repeated instances are seen from that Member. There are plenty of different Club areas that encompass 99% of Ford related posts, please select and use the correct one. If anyone is not sure of which area to post something then feel free to P/M myself or other Senior Staff for guidance. The Moderating Staff are having to spend far too much time chasing this problem instead of maintaining the other areas of the forum.


Big Lib

Budding Enthusiast
  • Content count

    5
  • Joined

  • Last visited

About Big Lib

  • Rank
    Newbie

Profile Information

  • Gender*
    Male
  • Ford Model
    Fiesta
  • Ford Year
    2008
  • UK/Ireland Location
    RhonddaCynonTaff
  • Interests
    Classic Cars
    General Automotive
    Travel
    Food & Drink
    Entertainment
    Sports & Leisure

Previous Fields

  • Location
    Pontypridd
  1. Follow Up On Stolen Car

    Never accept the forst offer!
  2. Opinion Needed

    I agree with Stoney. Instead of just looking directly from the front, move around from left to right and see if you notice the brightness changing because of the dirction of the lights?
  3. '08 Fiesta (Mk7) Engine Management Trouble!

    Have I done something wrong? Will someone talk to me !!! :(
  4. First problem was the main 'Engine Warning Light' (the amber light in the shape of an engine) was on solid. Found a faulty spark plug, the centre anode was flopping about, never seen anything like it. Job done or so I thought. The next day with a loss of power the other engine management light came on, (amber exclamation mark in a circle) :(. Fortunately when the engine was turned off reset and it was fine. Had it checked out but could not find anything because it was reset! Said he had known about a fault with the accelerator plug which he'd taken off checked and replaced but if it continues, it must be a sensor problem and recommended a garage. Nothing happened for weeks but when the fault reappeared I cleaned the plug again and it seamed ok. I got myself a DTC reader. When the fault reappeared I read all the faults wrote them down and cleared them to compare to future DTC's logged. This didn't happen for months. Now it's happening regularly I've plugged in my reader only to find there are no DTC's logged? I even managed to get the fault with the reader plugged in but although the reader is telling me there is a fault there are no DTC's logged? <_< After reading some Bloglines this weekend noticed some talk of a possible Lambda sensor fault? Sorry about the lengthy story, any thoughts?
  5. Welcome to the Ford forums Big Lib :)