AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


Pagdin

Budding Enthusiast
  • Content count

    12
  • Joined

  • Last visited

About Pagdin

  • Rank
    Member

Profile Information

  • Ford Model Mondeo 2.0 tdci
  • UK/Ireland Location Essex
  1. Hi all, I have an issue where when driving it seems like the wheels now and then want to veer away from the held line. My local garage checked all the bushes etc all were fine so no ball joints on the wishbone or anything. The thing is the front left (passenger side) tyre is getting scrubbed on the outside so am wondering if the strut top mount having a damaged rubber might be the cause... shocks seems fine and wheel is not 'loose' so any advice would be much appreciated. Thanks.
  2. Have a pull left or right while driving. Mainly over uneven ground. Had the rack changed recently but was doing it prior to this. All bushes are fine so am wondering if this could be the strut top mount. Any advice would be much appreciated. Thanks.
  3. Had the injectors replaced, yet now I'm losing around 10 miles per gallon on average. Any ideas???
  4. Car always started, first turn of the key. Sometimes would be a bit rough but never cut out. Had the glow plug light issue etc, had injectors reconditioned and that was fine. Now, only on cold car starts then cuts out straight away. Almost as though there is an air bubble in the fuel which huts the injector and cuts out. If I start using the throttle, this will pass the cut out and then its fine. Other issue is on driving, generally around or just below 2k rpm it gets jumpy, stutter so to speak...accelerate and gone. I feel both of these are connected but am unsure where to start and have thrown too much money to the garage who have not diagnosed the issue. Any assistance or advice much appreciated please. Thanks.
  5. Flashing Glow Plug Light

    Thanks all. Problem now is engine management light has now come on!! Guesing only so many times the glowplug light coms ontill this will happen. Question, will continued running of the car mean it will give up..die!?!?
  6. Fault Code P0251!!!

    Thanks for that, only problem now is my engine management light has come on!! Am I in danger of the car failing if I continue to drive it?
  7. Flashing Glow Plug Light

    My light only starts,flashing when I hit around 3k rpm in 4th or above!! Interesting about the fuel filter..I didn't change mine on service as looked ok. I've done 17k in ten months, how often do they need changing. Also, what if I ran the tank lower than usual, perhaps the filter is buggered but how would this effect the running and cause the smoke etc??
  8. Fault Code P0251!!!

    Ok, I hear this has a broad meaning but need some advice. Car starts first time, easily. Increasing amount of smoke when cold only and running idle is rough. Glowplug light starts flashing only when accelerating over 2500-3000 rpm in 4th or above, 1st to 3rd no problems. Car can be driven with light flashing but on some occasions it has cut out and taken a bit of foot and gas to get going after which ok except for above. Recently changed oil, oil filter, air filter..not fuel filter as nit that old as done before being bought. Changed camshaft sensor today, problem still there. Common advice is that its injectors but before I consider that expense is there anything else this could be? I hear a leak test or blow test can be done, what is this and how is it done? Sorry, loads of info and questions but need to try and understand what's happening :-( Thanks
  9. Flashing Glow Plug Light

    Ok, if I have the injectors done...is it likely that something else major might go? Does the cost suggest its better to bin the car??
  10. Flashing Glow Plug Light

    So, I guess the next question is where can I get injectors that aren't gonna rip my arm off with cost??
  11. Flashing Glow Plug Light

    If its the injectors, could it be one or all that need replacing. Also would this explain why when driving, if I ease off the throttle and back on again it almost hickups or stutters, only slightly. And I guess it explains the rough idle!!
  12. Recently my 04 mondeo tdci has been runing a bit rough. When cold and stationary it sems to chug, or act as though it's running on less cylinders if you understand. Any aceleration or as driving it's fine. The oher day on the motorway i hd to drop down to fith due some idiot!! and one aceleration i suddenly noticed power loss and the glow plug light started flashing. I continued to work and on switching the engine off and back on the flashing had stopped!! Ok I thought. On the way home last night, while pulling onto the motorway I accelerated more than usual on entry and again, power loss and glow plug light started flashing. As with everyone else, i have read nuerous posts and they are all somewhat conering. Yes, since buying the car 10 months ago there seems to be more smoke (more white that anything) but only on start up when cold. A mate of mine plugged it in to his code reader the other week, nothing..no codes. I'm slightly concerned now!! Oh, did an oil change the other week too, oil filter, air filter etc and changed the boost hose as this was err, screwed Any advice etc would be much appreciated. Thank you.