Ford Owners Club - Ford Forums Messages

Club Announcements

Ford Fair 2016: Tickets and stand passes are now available to purchase. More info here.

Review your Ford: Help others when it comes to buying a car like yours and review your Ford now

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


trigger

Budding Enthusiast
  • Content count

    5
  • Joined

  • Last visited

About trigger

  • Rank
    Newbie

Profile Information

  • Ford Model modeo
  1. Hi. I have a 2007 S-Max 2.0l TDCI with 25000 miles. After a 2 mile run I noticed a small lack of power from the engine. When I got home I made sure the handbreak was off but I then noticed a oil burning smell coming form the back of the car. After looking underneath the car I saw the exhaust just behind the first box was glowing red with heat!!!! I turned the car off and then smoke started coming from the outside of the exhaust all the way down and from the engine bay. There is no sign of any oil leaks anywhere on the car. Any help of what it could be before I hand over my house deeds to Fords..
  2. Sat Nav/radio Fault

    Just a quick update. I have installed the update and as to date no problems with sat nav. The update does not work with the 2007 maps so now I have no satnav :( I rang up Ford today and ask for the latest maps for the unit and they said that the only disc avaiable is the 2007 disc I already have The website they said for me to try say's that it is main dealer only and the main dealer say's go to the website... can somebody spreed any light on this....please.
  3. Sat Nav/radio Fault

    Thanks for the reply. How do I apply the update or is it Ford dealer only?
  4. Hi all, My sat nav unit has just started to play up. Its a CG3537 unit(the touch screen one) in a 57 plate s-max. some days it will turn on and all is fine then other days it lights up as if it was turning on but nothing comes up on the screen and no sound. Any ideas on what this could be???? Thanks inadvance. Owen
  5. Sat Nav/radio Fault

    Hi all, My sat nav unit has just started to play up. Its a CG3537 unit(the touch screen one) in a 57 plate s-max. some days it will turn on and all is fine then other days it lights up as if it was turning on but nothing comes up on the screen and no sound. Any ideas on what this could be???? Thanks inadvance. Owen