• Announcements

    • Stoney871

      Posting in General Chat thread.   11/11/2017

      it has been noted that too many Members are posting messages in the General Chat area instead of the correct Forums. Any messages posted in the General Chat area that are not General Chat will be deleted without warning and offenders may recieve warning points if repeated instances are seen from that Member. There are plenty of different Club areas that encompass 99% of Ford related posts, please select and use the correct one. If anyone is not sure of which area to post something then feel free to P/M myself or other Senior Staff for guidance. The Moderating Staff are having to spend far too much time chasing this problem instead of maintaining the other areas of the forum.


redfox9361

Budding Enthusiast
  • Content count

    6
  • Joined

  • Last visited

About redfox9361

  • Rank
    Newbie
  • Birthday 12/06/1946

Contact Methods

  • MSN
    adiesumner@outlook.com
  • First Name
    adrian

Profile Information

  • Gender*
    Male
  • Ford Model
    mondeo 2009 titanium x auto tdi
  • Ford Year
    2009
  • UK/Ireland Location
    Lancashire
  • Interests
    Classic Cars
    General Automotive
    Road Trips
    Food & Drink
    Computers & Electronics
    Literature

Previous Fields

  • Location
    prescot, merseyside
  1. Mk4 Mondeo 2009. Titanium X./satnav.

    I have been told how to remove the cd and I will try the lens cleaner. Thanks for the tip I will let you know If it works.
  2. Hi, I am having a problem with my satnav unit. When I input info I get an error notice. All other functons, ie Bluetooth,cd player,radio, work fine although voice command has limited functionality.Can anyone help.Thank you.
  3. Parking Sensor Fault

    Hi jeebowhite, Thank you, bad earth,, problem solved.
  4. Parking Sensor Fault

    Hi Jeebowhite, beeper cmes on when reverse is engaged but stays on when drive is selected. I switch it off on dash.
  5. Hi, I have a 2009 mondeo titanium X tdi auto and the parking sensors are making a continuous noise, I think from the rear sensors. Anyone know whats wrong and can it be fixed. Thank you. Redfox 9361. :(
  6. Welcome to the Ford forums redfox9361 :)