• Announcements

    • Stoney871

      Posting in General Chat thread.   11/11/2017

      it has been noted that too many Members are posting messages in the General Chat area instead of the correct Forums. Any messages posted in the General Chat area that are not General Chat will be deleted without warning and offenders may recieve warning points if repeated instances are seen from that Member. There are plenty of different Club areas that encompass 99% of Ford related posts, please select and use the correct one. If anyone is not sure of which area to post something then feel free to P/M myself or other Senior Staff for guidance. The Moderating Staff are having to spend far too much time chasing this problem instead of maintaining the other areas of the forum.


benskinley

Budding Enthusiast
  • Content count

    2
  • Joined

  • Last visited

About benskinley

  • Rank
    Newbie

Profile Information

  • Ford Model
    Ford Focus 1.6
  • UK/Ireland Location
    Sussex
  1. Mk1 Instrument Cluster Problem

    Hi there My car is in the garage as we speak, and they agreed to do the work for £99 plus VAT not including diagnostic. This is a rate Ford agreed after a watchdog programme highlighted the common Focus cluster problem. I took the car in this morning and signed a form saying £99 plus VAT and I now get a call at 3pm saying they can't do that price and it will be £229 plus VAT. Am I within my rights to take this further? Also, can I ask which Ford garage did your repair and how much they charged, as this cost shouldn't be any different!!!
  2. Mk1 Instrument Cluster Problem

    Hi there I've joined this site to talk about my car problem and it seems its exactly the same as yours! I have a 2003 1.6 petrol focus. It juddered a few months ago and I had the coil pack changed and everything was fine. Then intermittently I would be driving and the cluster goes wild and goes up an down (as if power goes for a few seconds) with the engine management light going on and off. This comes and goes an has been going on for a few months. Then recently the exclamation mark light and battery light sometimes come on along with the engine management light, absolutely no dials and just dashes where the mileage should be. Then after 15 to 20 mins everything comes back again. The car drives absolutely fine and there has been absolutely no difference in performance at all. Do you think it's the same problem? Also can you tell me exactly what you had to get done and estimate of cost? I don't want to get ripped off, I have heard people being charged £500 to get diagnostics and clusters changed! Your help would be amazing. Many thanks! Ben
  3. Welcome to the Ford forums benskinley :)