• Announcements

    • Stoney871

      Posting in General Chat thread.   11/11/2017

      it has been noted that too many Members are posting messages in the General Chat area instead of the correct Forums. Any messages posted in the General Chat area that are not General Chat will be deleted without warning and offenders may recieve warning points if repeated instances are seen from that Member. There are plenty of different Club areas that encompass 99% of Ford related posts, please select and use the correct one. If anyone is not sure of which area to post something then feel free to P/M myself or other Senior Staff for guidance. The Moderating Staff are having to spend far too much time chasing this problem instead of maintaining the other areas of the forum.


muddy

Budding Enthusiast
  • Content count

    3
  • Joined

  • Last visited

About muddy

  • Rank
    Newbie

Profile Information

  • Ford Model
    Mondeo 2L TDCI
  • UK/Ireland Location
    Suffolk
  1. Ok, firstly, excuse my mishaps with names of things I don't know about. ;) My husband knows what he's doing thankfully and has tested the earth wire, the voltage etc...he's also made sure all connections on the battery are good. Luckily we have a good guy look after my car who I trust to do jobs properly, he is a self employed mechanic and a good friend. He is going to double check all that dh has checked, this afternoon. We've had a few quotes for 2nd hand alternators so its looking like we may order one of those to arrive tomorrow. Fingers crossed. Honestly, I'm so sick of spending money on this car!
  2. Hi, I hope someone can advise me. I drive a 2003 Mondeo tdci estate. I had a new battery fitted a couple of weeks ago after car wouldn't start. Been perfect since. Until last night that is... I was driving home in the dark on my own so not an ideal time to break down. All seemed fine then all of a sudden I noticed the ABS light come on. Then all the lights on the dash slowly dimmed and the ABS light went off and as I pulled into a parking spot (thank goodness) the car just died. It wouldn't start again. I called my husband for him to come get me, but whilst waiting I tried car again (after about 5 minute interval) and it started, so I risked driving home as I wasn't far away then. It got me home. My husband has tested battery with his ammeter and it doesn't appear to be charging. Do you think I need a new alternator or could it be something else/something more simple and cheaper! lol Any advice greatly appreciated! Regards, Katherin
  3. Welcome to the Ford forums muddy :)