Ford Owners Club - Ford Forums Messages

Club Announcements

Discounted Car Insurance: Owners Club insurance could save you money on your car insurance. Get a quote

Review your Ford: Help others when it comes to buying a car like yours and review your Ford now

Ford Car Parts: View All ford car parts by category. Look for Ford Car Parts now!


teo_st

Budding Enthusiast
  • Content count

    4
  • Joined

  • Last visited

About teo_st

  • Rank
    Newbie

Contact Methods

  • MSN
    teo.usa.ohio@gmail.com
  • Skype
    teo_sk8
  • First Name
    Teodor

Profile Information

  • Gender*
    Male
  • Ford Model
    Focus mk2
  • Ford Year
    2005
  • UK/Ireland Location
    Other/NonUK
  • Annual Mileage
    0 to 5000

Previous Fields

  • Location
    Bulgaria
  1. Sorry for being offline so long. The Focus before 03.2005 has that extra relay in the boot and only is has that kind of problem. The newer version 04.2005- did not have it. I have both cars :) I can't make a picture so show you exactly where is located so I will try to use someone's on the web. Hope he doesn't mind. Mine was taped so look carefully. Good luck!
  2. Hi, I have solved the problem! The relay was damaged. It is located in the trunk on the left side. I am so happy about solving it ! Good luck
  3. Yes, but the relay is integrated... I removed all the relays from the fuse box and the wiper is still working and the relay is clicking from the inside...
  4. Hi, I am new in this forum and I have the exact same problem. I have ford focus mk2 year 2005. This is my second car. I used to have the same focus but 2007. But I crashed it and now I am selling it ofr parts. About the problem. I have replaced the motor with the motor from my old car that is 100% working and the result is negative. The wiper stops wherever it wants to. I checked the cables in the rubber housing between the trunk and the car but everything seems to look good. The only thing that left is the build in "indestructible" relay. I someone has any suggestions please tell me I will try to fix it. I am sorry for my bad English.
  5. Welcome to the Ford forums teo_st :)