Ken davies

Budding Enthusiast
  • Content count

    5
  • Joined

  • Last visited

About Ken davies

  • Rank
    Newbie
  • Birthday

Profile Information

  • Ford Model
    Titanium 2.2 TDCI
  • UK/Ireland Location
    Yorkshire
  1. Hi gary. Thanks for ur reply I dont know if i have a bad problem or not. On starting the revs are on around 500, after a couple of secs it revs at normal. However on inspecting that cover there is a lever housed in it, when revs go to normal running that lever clicks forward. Would u know the problem.???? Cheers buddy.
  2. Hi all. Can somebody explain what this is in picture. On start up the revs are low (not all the time). However this last a couple of secs, there is a lever in box that clicks forward then engibe runs like a dream.????? Hope i have explained the problem
  3. Hi Darren, Not many speed bumps, but when I do come across them I slow right down to go over them, I use my local garage, he orders them but I dont know from whom, I have been told to go to fords to get the springs then have my local garage fit them. This I will do if and when another spring goes. Vheers for the reply bud
  4. Hi all, I bought a 2006 2.2 Mondeo Titanium mk3 in may 2012, since I bought it In the first month I had a coil spring snap on F/O/S, this was covered under warrenty, this year however I have had 3 more coil springs snap, F/O/S again, rear O/S and today F/N/S, I dont know if its bad springs or Im just lucky,lol. When I bought the car there was just over 61000 on the clock it now has just over 68000, so its not like i drive it much, two of the springs have snpped whilst parked outside the house, which I know is very hard to believe, I have been all over the web, and my findings have come up with mondeo's hate springs, please can anyone shed some light on this
  5. Welcome to the Ford forums Ken davies :)

    1. Ken davies

      Ken davies

      Hi steve thanks, I have a problem with my 2.2 ford moneo titanium x, it was first registerd in 2006, I bought the car in may 2009, this year however I have fitted 4 coil springs, 2 FOS, 1 ROS and today another went on NFS, this is starting to really wind me up, I havent had ford put new one on just my local garage, is there a problem with mondeo's,