fairlo

Budding Enthusiast
  • Content count

    5
  • Joined

  • Last visited

About fairlo

  • Rank
    Newbie

Profile Information

  • Ford Model
    2002 mondeo tddi
  • UK/Ireland Location
    Tyne & Wear
  1. Hi all i have just picked up my new (new to me) 2000 ford galaxy and my first two jobs are the front electric windows which wont go up or down on either drivers or passenger side and the central locking which also is not working, i went straight for the obvious, the fuses which were both in good condition and working as they should so am after some pointers for what my next step should be to fix these none working items. I am guessing that as neither windows work the prob is unlikely to be local to the individual motors? thanks in advance guys :)
  2. Hi again I fitted the egr blanking plate and took the car for a drive around my block. It complete the block 4 times (7minutes) then the miss started again, again stopping the car reving cleanly and producing blue smoke and when I turned it off it refused to start, cranked over but would not fire. Again no warning lights at all and feels mechanical foot on the floor and it fights to rev struggling most between 2-3000 rpm. Any ideas what I should try next please the brake down man tried 2 diff codes readers but they wouldn't communicate with the car. Thanks again guys
  3. Update Got back to the car this morning, turned the key and it fired up first time with no issues or sign of the blue smoke. Dint fancy driving it back in case it threw another fit, so called out a brakedown van to have it recovered, they guy checked the car over and said he couldn;t see anything obvious and that obviously it was running fine now, he like a number of members on here suggested it sounded like an egr valve playing up, so i have ordered the backing plate to block the valve off and fingers crossed this will solve the issue, but ill keep you upto date, thanks for all the help and sugestions so far its much appriciated. thanks
  4. unfortunately returning the car is not an option so going to have to try and get a fix sorted am going to hopefully have it recovered to my house on Monday, ill repost then with a bit more info about its symptoms but a big thanks for the suggestions so far guys.
  5. Hi all i have just bought a 2002 tddi (115bhp) mondeo it has 110,000 on the clock. Picked it up and all was well started no problems after a battery bump all warning light went out and all was well, was driving along and the car was smooth and pulled well, then there was a blip/pause in acceleration. over the next 10 mins these pauses became worse until the car would no longer accelerate or rev and lots of blue smoke was coming out from the rear then the car stopped running and would not restart, after leaving it for around 10 mins it eventually started again but was not reving cleanily and could only get it to creep forward on idle revs before it stopped running and again would not restart. there are no warning lights on the dashboard at all. Any help would be much appriciated as the car is stranded 40 miles from my home and i am unsure as where to start looking for the cause of the issue. thanks in advance guys
  6. Welcome to the Ford forums fairlo :)