Pontylad

Budding Enthusiast
  • Content count

    7
  • Joined

  • Last visited

About Pontylad

  • Rank
    Newbie
  • Birthday 11/11/1945

Contact Methods

  • MSN
    terannett@talktalk.net
  • First Name
    Terence

Profile Information

  • Gender*
    Male
  • Ford Model
    C Max 1.8 TDCI Titanium
  • Ford Year
    2007
  • UK/Ireland Location
    RhonddaCynonTaff
  • Annual Mileage
    10,001 to 15,000
  • Interests
    General Automotive

Previous Fields

  • Location
    United Kingdom
  1. Same problem with me. I have had a new egr valve put on but no difference -this comes with a manifold so big bucks. Also main Sensors cleaned & have had it diagnosed 4 times including a Ford job which took a full day and still didn't pick anything up. I'm going to have a real look at what is causing this problem. Is there some kind of sensor, limiter or governor tucked away somewhere which is interfering with it. Could it be an electronic sensor going wonky that Fords didn't pick up. Pontylad S.Wales
  2. Good to know the ford Focus is a good choice. First thing to do is to have an oil/filter change (like a blood transfusion) unless it's had one recently. I've had a couple of fords, an Anglia (sloping back window),and escort, and Mark 2 & Mk 4 Cortinas. Good workhorses as your Dad will know. Trouble is you can't get to work on modern cars unless you are a mechanic. Lots of electronics as well and emissions stuff. Pontylad .
  3. Looks like a nice car. I've had my 1.8 TDCI 27 months. Had any problems? I've had a few Pontylad
  4. Thanks navarro93. I'll see what comes up on Diag now that I've booked in but I'll get garage to look at hoses as It's worth a try.
  5. Could be frozen but Is the fuse controlling anything else. It may be shown on a wiring diagram. Might be that although fuse is intact it may not be making contact. Have you tried cleaning the blades or trying a new fuse. Other probs could be a loose connection or a relay not making contact or duff. 'm sorry I can't be more help. Good luck Pete Pontylad.
  6. I've read a few strings on this but as others have described, and a common problem it seems, my 07 plate c max 1.8 TDCI is ok at low speeds but loses power when pedal is floored as on a hill or at speed or trying to pass a slower vehicle as if there is fuel starvation but returns when i ease off. I've had sensors cleaned and EGR valve replaced (on this car it comes with the manifold) - big bucks. I don't know what to believe, as several answers have been given.... MAF, pedal sensor, Fuel line weakness, etc.. It starts ok, as new starter motor, battery, alternator and glow plugs have just been fitted. It also had recent fuel/air filters and oil change. Anyway, may be a waste of time and money but I'm booked into Fords for a £75 diagnostics check which may not show any codes, or may open a big can of worms. If no codes come up what next. Anything positive welcomed. Pontylad
  7. Hi everyone I go under to name Pontylad and own a C max 1.8 TDCi Titanium 07 plate down in South Wales I have had this car just over 2 years and tow on occasions when the sun is out a 2 berth bailey ranger tourer which it has no problem with.
  8. Welcome to the Ford forums Pontylad :)