Ford Owners Club - Ford Forums Messages

Club Announcements

Discounted Car Insurance: Owners Club insurance could save you money on your car insurance. Get a quote

Review your Ford: Help others when it comes to buying a car like yours and review your Ford now

Ford Car Parts: View All ford car parts by category. Look for Ford Car Parts now!

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


jmeader

New Member
  • Content count

    1
  • Joined

  • Last visited

About jmeader

  • Rank
    Newbie

Profile Information

  • Ford Model
    Fiesta Zetec mk4 1.25 16v
  • UK/Ireland Location
    Kent
  1. Ive just had a garage "fix" this problem that lasted a week before it returned They said they replaced the relay behind the steering column which they said was very awkward to access because it was right up behind the dash I found a 2amp glass fuse left on the passenger footwell and im wondering if this points to something else that was actually done instead of changing the relay which would mean ive been ripped off I wondered if i should attempt to remove the relay myself and confirm with ford if its the original or aftermarket as ive had the car from new and i know this has never been replaced before The loss of indicators and heating is a total failure usually after the engine has been off for a while and returns with no warning or with me aggrevating it by turning the heater blower on between 1-4 speed or moving the indicator stalk up and down My hazard lights work and the indicator lights work on the dash despite the actual indicator stalk not working The 2 problems are directly linked and fail at the same time every time as i have tested this theory by leaving the indicator stalk up or down and the heater blower on a speed of 1-4 and they both magically come back on at random points I have also noticed a loss of heat that started to happen a few days ago and was noticable before it went into the garage I hope this is enough of a description and im keen to hear your thoughts especially about whether you think the relay the garage supposedly changed has any bearing on the original problem and especially how an indicator relay can be anything to do with the heater blower? Prior to this problem the garage said they fixed a coolant leak by changing the water pump, theromostat housing and another major part which all resulted in a bill of £410.00
  2. Welcome to the Ford forums jmeader :)