AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


Budding Enthusiast
  • Content count

  • Joined

  • Last visited

About brirob24

  • Rank

Profile Information

  • Gender*
  • Ford Model
    Focus ST170
  • Ford Year
  • UK/Ireland Location
  • Annual Mileage
    0 to 5000
  • Interests
    General Automotive
    Motorsport & Racing
    Road Trips
    Food & Drink
    Computers & Electronics
  1. Thanks for all of the info, wasn't sure if the 1500 rpm tickover was just the ecu doing its job, i just don't recall it doing it when i first got the car, maybe it does it more in the colder weather? I've had it about 3 months, also I don't recall it having the slight flat spot when i got it, but then recently I have been driving it at lower revs due to the weather. Looking forward to some slightly warmer weather so can start driving it 'properly' again! If it doesn't improve after its been having a decent amount of revs I'll change the plugs and HT leads (it had a recent air & oil filter change) or try Vaseline first! Thanks again
  2. Hi all My 2004 St170 is very slghtly 'lumpy' at exactly 2000 revs - feesl like a very slight misfire, also it over revs on tickover to approx 1500 rpm on a cold start (soon goes back to normal after a few miles). does anyone have any suggestions before i start paying (i'm thinking of getting it computer tuned anyway). I'm thinking the lumpiness may be plugs or HT leads?? Thanks everyone
  3. Ok I found the original connector in place fixed behind the door card exactly where it should be! Previous owner mustn't have realised and had just cut wires off in the mirror Note to self : look properly next time!
  4. Hi All Just got myself a great 2004 ST170, very pleased with it so far has to be the best car I've ever owned. Looking forward to getting in touch with other ford owners and helping out when I can! Cheers
  5. Am hoping someone can help! I'm trying to replace the passengers door mirror on my st170, but the wiring colours on the new mirror don't quite match the wiring on the car, and the previous owner has very helpfully cut off the socket on the car! There are 5 wires on the new mirror ( 2 black, 1 green, 1 brown, 1 white ) and on the car there are 6 (2 black, 1 green, 1 brown, 2 grey). All the wires on the new mirror have a silver band. I'm guessing that the same colours go together but don't know what to do with the 1 white and 2 grey - don't want to risk just joining them together! thanks
  6. Welcome to the Ford forums brirob24 :)