termin8r

Budding Enthusiast
  • Content count

    2
  • Joined

  • Last visited

About termin8r

  • Rank
    Newbie

Profile Information

  • Ford Model
    smax 2.0 tdci zetec
  • UK/Ireland Location
    Antrim
  1. Thanks for your response. I also have another car which is petrol and "fly by wire" accelerator also. It idles around 7-800rpm. When i (in neutral) press the accelerator extremely gently the revs rise slowly as expected and it is a very linear and smooth response. In the SMAX it idles around the same but pressing the accelerator in the same manner results in no increase in engine revs until a certain point where it just snaps to 2000rpm or above. This symptom would indicate point 1 or 5 above. It is not turbo lag or clutch related as I am in neutral and the car is not moving. I ran the ford garage and they told me to ring the technical number. But at £1 per minute, why should i have to do that on a new car?? Just wondering if anyone else has an 2012 smax and whether it does the same thing.
  2. Hello everyone. I'm new to ford ownership. Bought a pre-reg with 0 miles smax in October. It is 2.0 TDCI zetec. Already had the window motors replaced on the front. Bad start.. Next issue seems to be the non-linear reponse from the accelerator which causes difficulty in taking off from stopped. If i press the accelerator slowly whilst in neutral , there is no reponse from the engine. At a certain point it then jumps straight to around 2000rpm or higher. Why is this? My friend you co-incidently bought the same car seems to have the same problem although i have not tested their car. ECU anomaly? It certainly makes the car hard to drive without either conking out or revving it excessively, Any ideas? Sam.
  3. Welcome to the Ford forums termin8r :)