AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


guairek

Budding Enthusiast
  • Content count

    6
  • Joined

  • Last visited

About guairek

  • Rank
    Newbie

Profile Information

  • Ford Model
    Ford SMax 2.2 TDci TiT
  • UK/Ireland Location
    Derbyshire
  1. This engine swap is prooving to be a nightmare. I am still stuck and now don't know what to do. Is there anyone out there who has done an engine swap on one of these? Thanks Guaire
  2. Hi Foca The new engine, going on the word of the breakers here. Came from a 2009, LHD, Polish Origin, 2.2 Smax Titanium that had be rolled, having covered 20k. The breaker Goldseal aka Universal Car parts‏ in London is trying to dig out the Reg as proof. No didn't here it running. I am told we are getting a max of 10psi and I am told it needs to be 300psi ish. What has been tried so far. Swapped injectors from old engine to new, complete with pump, fuel rail & fuel filter. From what I saw the return & supply lines are different sizes so can't be mixed up. Am I looking at the wrong thing? Recoded ECU using Launch x431 2008 update onwards, reads vehicle code as 3g3a32-12k532-dl, the k could be an x though as its hard to read. Tried gravity feeding the with no luck. Any idea what the low preasure pump and high preasure pump should be opperating at preasure wise? Tried pull start with no affect Tried ez start, starts briefly. I think this proves its not flooded? doesn't it? Suggestions I have been given to try: Get one or both sets of injectors checked by specilists. told if these are not opereating properly they will not signal draw fuel. Check fuel rail preasure sensor. Fuel rail preasure release vale stuck or dirty on both. mainfests it self as: prevent fuel delivery being signaled. Flywheel at fault, misalligned etc. mainfests it self as: wouldn't request fuel. I would say read herring as it would at some stage request fuel so preasure would build to required level. The plan going forward. Saturday, get access to fuel tank pump and see if its working. If it is work my way back up to the rail to see if Diesel is being supplied all the way to the HP pump. After refitting the engine i noticed one single wire four pin connector on the loom loose near the HP pump. I spent 2 hours looking for where this could be from but couldn't find an empty connector to receive it. I could do with a diagram or similar to eliminate this as a cause, if any one has one. As you can tell I'm not a mechanic, so sorry for any incorrect terms or references. Thanks in advance Guaire
  3. Cheers for the replies. I got a replacement 2.2 from a 2009 & its in and programmed up. It doesn't have any fuel preasure at the rail though. I am on my 4th mechanic one being a senior tech from ford with all the gadgets, they all say its ready to go but won't fire up. It will briefly start with the help of some easy start in the inlet (I think it was) though. Any ideas? I am thinking cam position sensors myself, anyone know the location as I have my old lump to hand, maybe swap them over? We have tried two pumps & two sets of injectors old and new. The only error that comes up is no cam signal, all 4 said it was due to no fuel rail preasure present. Not sure if this makes any difference but while the car was parked up, some git drained all the diesel from it. We had refill and bleed it to get it to come through. Anyone got any ideas why no fuel preassure to 2nd pump? Thanks Guaire
  4. Hi The replacement engine looks the same but has different engine mounts etc. Does anyone know how to check the engine number to find out what it came out of? Thanks Guaire
  5. Hi Minitalkin Thats for the advice, What about the pump? Thanks again Guaire
  6. Hi All I decided to replace the engine in my 2008 2.2 TDci (PSA variant) SMax TiT due to a cylinder head fault from an overheat. Does anyone know if I need to swap the Injectors & Pump from the old engine to the Donor engine or will the ECU accomadate the changed hardware? If they don't need to be swapped does any ECU re-programming need to be done? Thanks and merry Christmas to you all. Guaire
  7. Welcome to the Ford forums guairek :)