Budding Enthusiast
  • Content count

  • Joined

  • Last visited

About thc6

  • Rank

Profile Information

  • Gender*
  • Ford Model
    Focus mk2
  • Ford Year
  • Annual Mileage
    0 to 5000
  1. So I was looking at these on ebay for under £15, but just noticed the two sets I was looking at seem to have slightly different shape fittings? The first pair seem slightly more trimmed..|Plat_Gen%3AMK+II&hash=item2a2cd7acf0|Plat_Gen%3AMK+II&hash=item1c361b531c Only thing that concerns me is the second set seem to have a pretty random selection of cars it apparently won't fit: "ST / RS / ZETEC / TITANIUM / 1.8 Tdci 2006 / 1.6Tdci Ghia / ZX3" Can anyone that's bought these before give me a heads up on if they're likely to be a bad fit or anything? Thanks!
  2. OK, so I managed to retrieve the bulb holder which was somehow buried right down in the bottom corner. Seems to be working fine, although it is currently sporting a spare indicator bulb which is a bit on the dull side. Regarding the leak after heavy rain especially overnight, there are visible water droplets on the carpet on the passenger side boot wall - would you expect this is coming from around the spoiler area mentioned above or could it potentially be coming through the light fitting or something?
  3. Cheers for that - it wasn't a Ford dealer so that might go some way to explaining, though you'd still expect them to have come accross this issue in the past. Think I might be having an issue with slight damp in the boot again at the moment so I might have to revisit that soon, seem to keep getting condensation inside windows. I'm guessing they didn't make a great job of it..
  4. Thanks for confirming, I'll have a proper look tomorrow. Is it fairly easy to remove the trim around the side of the boot? The dealer had pulled alot of the plastic trim out trying to identify the source of a leak in the boot last year, so guessing that might have been when it happened..
  5. Hi, I've had my car nearly a year now but in that time the boot light has never worked. Finally got round to looking at it today, but when I removed the plastic lense cover (drivers side rear corner of the boot), there seems to be no fitting for the light underneath! This might just be a stupid question, but did all mk2 models have a light fitting wired to the boot? My only other guess is that at some point the trim has been removed and the light fitting got knocked out of place - so before I start removing trim I just wanted to make sure there should actually be a fitting in there somewhere? Thanks in advance!
  6. Having looked at a 1.6, I ended up going for the 2.0 TDCi, I found there wasn't a huge amount of difference in the insurance cost, just tax slightly more expensive. There are alot more cars to choose from if you go for the 1.6 or 1.8 though. For me the computer shows the mpg at approx 45 so far, but I'm not sure how accurate this is. I'd be more concerned for the DPF issues if the car has done low mileage for its age or is approaching 100k and hasn't yet had it replaced. I'd also be watching out for symptoms of dual mass flywheel failure, again depending on the mileage of the cars you're looking at.
  7. Apologies for the slow reply, but any chance you could elaborate on this? I've had a quick search around - I take it this still a job that would require the clutch out? I've also noticed a slight rumble(?) when stationary in neutral maybe every 20-30 secs on average - would you say this is more likely to be flywheel related? On another possibly related note, the car doesn't always start on the first attempt - perhaps 30% of the time. When it fails to do so, it always starts straight away second time. Is this common in Ford diesels? Cheers
  8. I bought a 2005 Titanium, and whilst it has a few extras such as the half leather and Sony headunit, I think the spec overall is slightly lower than the 2001 Leon I had prior to the Focus. Pricewise, I don't think the Titanium has much of a premium over the Zetec or Ghia trims, at least not amongst the 2.0 TDCIs - it's just they are harder to come by in the first place.
  9. This had crossed my mind, but the car seems alright running in all gears, I have literally just noticed this when at a standstill. The car doesn't seem to be rattling or shuddering whilst driving, although I suppose it could be in the early stages?
  10. Afternoon everyone, New member, and just got my first Focus, so hoping I'm just being a bit paranoid here! The car seems to run fine generally, but when I press the clutch pedal right down it seems to make a noise - I wouldn't describe it as a loud rattle or anything - but it is different from the engine note at idle with the clutch up? It only happens when the clutch is right down. The clutch does feel quite high compared to my previous car, so I guess it's not a million miles away from replacement. Apologies if I've described that a bit vaguely, I'll try and provide clarification if needed! The car is a 2005 tdci, approx 77k miles. Thanks in advance :)
  11. Welcome to the Ford forums thc6 :)