Ford Owners Club - Ford Forums Messages

Club Announcements

Ford Fair 2016: Tickets and stand passes are now available to purchase. More info here.

Review your Ford: Help others when it comes to buying a car like yours and review your Ford now

Ford Car Parts: View All ford car parts by category. Look for Ford Car Parts now!

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


deaconj999focus

Budding Enthusiast
  • Content count

    11
  • Joined

  • Last visited

About deaconj999focus

  • Rank
    Member

Contact Methods

  • First Name
    Joe

Profile Information

  • Gender*
    Male
  • Ford Model
    Focus Mk 2.5 1.6 TDCi Titanium
  • Ford Year
    2008
  • UK/Ireland Location
    Newport
  • Annual Mileage
    5001 to 10,000
  • Interests
    General Automotive
    Car Modification
    Road Trips
    Food & Drink
    Computers & Electronics

Previous Fields

  • Location
    Newport S Wales
  1. Guys, A few times recently my focus TITANIUM TDCI 1560cc DIESEL at around 70-80 mph after travelling for about 2 hrs suddenly decides to do what I can only explain as lurching. Firsr time it happened was about 2 weeks ago on the motorway and there are no lights that come on, the rev counter stays steady and I experience a very weak lurch and accelerating kind of motion, no real engine sounds or knocking, pinking etc, infact only smooth deceleration and speed restoring, no un controlled excessive engine speed either. This happened about 8 times in succession and when I dropped to 60 it then ran as normal. After a few minutes at this speed I was able to bring the speed back up and continue my journey. My local very good and friendly garage put a diagnostic test device on it and it seemed to show the DP filter had tried to 'recharge/reset' itself. I can't remember the exact words the mechanic used. It has a brand new (12 months or so) DPF and I run it regualrly about once a month in 4th gear to burn of the carbon, because most of its werkly 2xdaily journeys are about 7 miles each. I know, I know. LOL (Wifes work car). Should have got a Petrol one etc for short journeys. However, around town speeds I have none of these lurching symptoms. Same happened a few ago on motorway again, even in cruise control mode or if I am using the accelerator foor pedal. Today after about 2.5 hours same speed on cruise control it happened again. So I turned the radio off and as it decelerated I could hear a kind of slipping sound best described as a slipping fan belt but no squeak more like a rubber belt faintly whooshing on a plastic pully is what I had pictured in my mid. The faint noise matched times the car decelerated and eased off when the speed smoothly came back. When this event begins it usually lasts about a minute or so and I did notice today that whilst the event was happening and I purposely pressed the accelerator it exaherated the lurching feeling. But this time as I eased off the speed the noise went away and the lurching stopped. So, is there some sort of fuel pump that may be slipped when its belt gets warm and is losing a bit of friction on which makes the engine lose power and then pick back up again. Its a bit like its retarding and advancing but with only a faint belty plasticy very faint rubbing whooshing sound which wasn;t even loud enough to capture on my phone over the road noise. Any help would be really appreciated.
  2. Thanks for the welcome :)
  3. Hi, I'm looking for the blue version of most of what you did above, did you not use canbus error free types? I also have a mk2.5 tit tdci Thanks
  4. Hi Guys, With a 85 plate mk2.5 focus titanium do I need canbus leds, I am aiming to change the courtesy x2 and map lights, footwells and sidelights. I think the festoons are 36mm on my car and the map lights are bayonets. Any advise please
  5. I wonder if I should get these http://www.ebay.co.uk/itm/4-x-ERROR-FREE-CANBUS-5-SMD-CAR-LED-BLUE-W5W-T10-501-SIDE-LIGHT-BULBS-BLUE-/320865983677?pt=UK_CarsParts_Vehicles_CarParts_SM&hash=item4ab51a5cbd as they are error free !!!! and I could use two of them in the footwells, the other two in the interior with this one 36mm in the centre http://www.ebay.co.uk/itm/1-x-36MM-2-SMD-LED-FESTOON-CANBUS-NUMBER-PLATE-INTERIOR-BULB-Blue-/220981512753?pt=UK_CarsParts_Vehicles_CarParts_SM&hash=item3373864a31 am I on target here please?
  6. Looking good thanks for the link
  7. These 5w white / clear bulbs can be replaced by blue ones but can you get direct blue replacements or leds that fit in the same socket. I suppose I need to search ebay for 5w blue bulbs, I don't always state the obvious................. Anyone got a link for the bulbs ??
  8. See if this is it, http://www.fordparts...02786_c_340.htm On the site you can choose your model Joe
  9. Hi all, Owner of a focus tit for less than a week, can't find any useful info in the handbook wrt these Qs: Do the indicator lights flash when locking and unlocking ? Mine seem to but is there a possibility I have pressed the buttons on the remote too long and altered the function? What's causing the message display 'bonnet open' even when the bonnet is firmly shut? Why does the A/C button light up every time the ignition is on? Is there a way of preventing this annoying feature ? Please help as my new car is now seemingly annoying and therefore becoming a bit of a let down, when it seemed so nice. Regards Joe
  10. Hi Guys, Mine don't flash at all on my Focus Tit 1.6 TDCI, anyone know why as I just bought it less than a week ago and still working out what it does and doesn't do.
  11. Hi, hopefully my fears about my focus can be answered here.
  12. Welcome to the Ford forums deaconj999focus :)