AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.

Maggy dave

Budding Enthusiast
  • Content count

  • Joined

  • Last visited

About Maggy dave

  • Rank

Profile Information

  • Gender*
  • Ford Model
    Ford fiesta style 1.4
  • UK/Ireland Location
  • Annual Mileage
    0 to 5000
  1. Thanks for that guys funny enough iv never heard the fan kick in but the temp never goes above half way . The core plug on the left of the engine was rotton as a pair the one on the right was rusted but didn't leak but I replaced it just to be on the safe side . It just seemed odd that it's leaked there again and out the pump , I'm seriously considering putting a engine in it out of the scrapers and selling it !
  2. But why the water round the plugs ??? After 4 weeks of running mint ,
  3. My Missis 55 plate fiesta had a bad coolant leak I tracked it down to the core plugs in the top of the head I replaced both of them and its been fine for 4 weeks then this week se broke down on the way to work there was no coolant in the tank (I'd checked it the day before an it was fine )I checked the head and the left hand side was full of water just like before I pulled the water out with a syrine wiped round the core plug but couldn't find any gaps or holes I topped the coolant up and run the engine to see if it leaked but Streight away it was humping out the water pump mountings could the engine be pressurising and pushing it out were it can and if so why? There's I'd no water or cream in the oil , should I try a small hole in the header tank cap to release pressure ??
  4. Welcome to the Ford forums Maggy dave :)

    1. Maggy dave

      Maggy dave

      Thank you very much