benj3941

Budding Enthusiast
  • Content count

    6
  • Joined

  • Last visited

About benj3941

  • Rank
    Newbie

Profile Information

  • Ford Model
    mondeo
  • UK/Ireland Location
    Suffolk
  1. Got an 07 plate tdci had injectors and egr valve replaced and. Still smokes like hell under acceleration so not sure where to go from here!
  2. alright guys sorry about the slow update been busy working (to pay off the huge bill) but the money ws spent 16000 miles later is still running sweet as a nut, it feels quicker more economical and doesnt sound like it was been run on nails so thanks very much for the help and advice, will post when anoher problem arises thanks ben
  3. All right guys I'm after a/ some 18" 7 spoke titanium x alloys ( ruined by pothole ) thanks ben
  4. Yep as far as I'm aware it was removed emptied and checked for debris. And replaced with new
  5. Thanks guys they checked the codes can't remember what the codes were but was down to fuel pressure, they say they can't get a. True reading from the injectors bcoz the flywheel banging around so much
  6. Hi guys mondeo broke down before Christmas with the dreaded glow plug light, no limp mode just cut out completely, garage changed fuel pressure sensor with no effect tested injectors replaced one, now they are suggesting the flywheel is badly damaged and causing the injectors to try and balance the rough running (lumpy on tick over no smoke no prior running issues) due to the cost involved (2500 for both jobs)was jus after some advice if this is going to be the cure or things to come? Would be of great help.
  7. Welcome to the Ford forums benj3941 :)