AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


Tommy3010

Budding Enthusiast
  • Content count

    12
  • Joined

  • Last visited

About Tommy3010

  • Rank
    Member

Profile Information

  • Gender*
    Male
  • Ford Model
    Ford c max 1.6 tdi
  • Ford Year
    2004
  • UK/Ireland Location
    Essex
  • Annual Mileage
    10,001 to 15,000
  • Interests
    Classic Cars
    Car Restoration
    Car Modification
  1. Same as when u test spark plug then
  2. Ok thank you I have a look had a day were it did do it lol
  3. It ran the same with it off and no management light
  4. It ran the same with it off and no management light
  5. I was taking it as it wasn't that lol how you take it
  6. I had my egr valve change 9m ago so sure it's not that as for fuel filter how come I can turn key of then on again and it starts ok I unplugged maf sensor to and went round went for 10 mins and did it again so can't be maf sensor lol I do still love fords I do lol
  7. But there was loads of black smoke when it 1st than it now none lol just drive no problem them does it i just dont wont to spend 60 pound and its not it lol
  8. And how come at idle I can rev to max and not a thing just like normal
  9. Would u say to start with the fuel fitter and are they hard to change never changed a td one
  10. I had thought that too (Or maybe a failing fuel pump) but isn't the throttle of a diesel control by fuel flow (As opposed to a petrol car that is controlled by airflow), and therefore if the flow was restricted (Due to a dirty fuel filter or failing fuel pump) then wouldn't that just prevent the car from accelerating any further, rather than actually cutting out? I guess its not that simple with a turbo car as the fuel flow and airflow need to be in balance, so maybe with the fuel restricted the ECU detects that the mixture is way too lean and therefore cuts the power.... but if this were the case then I'd expect to see a fault code.
  11. It all started with what felt like a slight flat spot a few weeks ago. Today, car started fine, all going well for about 3 miles then suddenly at about 3000 revs a puff of black smoke and complete power loss ( all electrics stayed on ) had to re start engine while rolling down dual carriage way lol. Started first time, all was fine till between 3/4000 revs and same again. No engine fault lights. This car has had a new Egr valve less than 9 months ago, but when that happened, there was engine fault light, and it was in limp mode, this is not the same. Please help, any ideas appreciated. Thanks, Tom.
  12. Welcome to the Ford forums Tommy3010 :)