AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


Bakers Fiesta

Budding Enthusiast
  • Content count

    6
  • Joined

  • Last visited

About Bakers Fiesta

  • Rank
    Newbie

Profile Information

  • Ford Model Mk6 Fiesta Zetec s
  • UK/Ireland Location Suffolk
  1. Mk6 Fiesta Thermostat!!?!?!

    Hi guys!! I recently had a mot on my fiesta and passed :D!! However it was advised that I change my thermostat housing, as stains of coolant were found, so leaky housing! got a stupid price from ford dealer whereMOT'd of £200 + As I am not much of a mechanic, is it a easy fix and where is it located under the bonnet. if it helps I have a Ford Fiesta mk6 Zetec s! Cheers
  2. Thermostat Housing Repair Cost

    anyone have a pic where the thermostat housing is, as mine is leaking! :/
  3. Mk 6.5 Fiesta Interior

    ok thanks for your help!!
  4. Door Trim?

    any one know the part number for the door trim clips as a couple of mine broke? or any others that do the job?
  5. Mk 6.5 Fiesta Interior

    Hey!! I removed my door cards earlier this week to change my broken speakers, all went well other than a few door clips broken so will get around to replacing however I noticed my passenger side handle was not sitting flush unlike my drivers side but still locks and operates fine. (see pics) any quick fixes or idea what it could be as it just bugs me to look at!! Cheers
  6. Hi everyone New to all of this. so may be in wrong section so I apologise in advance. I have an issue with my Mk6 Fiesta Zetec s, Whereby when I do I cold start, the car will turn over start, then seconds later cut out. I then re-start again it turns over starts runs for like 5 seconds, then cuts out again then 3rd time lucky it works, which is good!. :D However on 2nd attempt the gauges/pins do not move at all!! (stay @0 although car is running) and the trip/mpg/avg speed are all reset back to 0??? Also my button on the end of the indicator stalk, to scroll thru menus is very temperamental any one else have this?? Cheers