• Announcements

    • Stoney871

      Posting in General Chat thread.   11/11/2017

      it has been noted that too many Members are posting messages in the General Chat area instead of the correct Forums. Any messages posted in the General Chat area that are not General Chat will be deleted without warning and offenders may recieve warning points if repeated instances are seen from that Member. There are plenty of different Club areas that encompass 99% of Ford related posts, please select and use the correct one. If anyone is not sure of which area to post something then feel free to P/M myself or other Senior Staff for guidance. The Moderating Staff are having to spend far too much time chasing this problem instead of maintaining the other areas of the forum.


clewsy7

Budding Enthusiast
  • Content count

    4
  • Joined

  • Last visited

Everything posted by clewsy7

  1. HI, I HAVE BEEN SERVICING MY FORD FOCUS TDCI 1.6L 2005 MYSELF AS I AM KEEN TO PICK UP THESE BASIC SKILLS. I HAVE HAD NO PROBLEM CHANGING THE OIL, OIL FILTER, AND AIR FILTER. MY PROBLEM IS FINDING A PLUG ON THE BOTTOM OF THE RADIATOR IN WHICH TO DRAIN THE OLD COOLANT - DOES ANYONE KNOW WHERE THIS IS?? IF SO CAN YOU SHOW ME USING A PHOTO IF POSSIBLE? ALTHOUGH DESCRIPTION WOULD SUFFICE! ALSO THE FUEL FILTER. ITS EASY TO ACCESS BUT THE PIPES THAT CONNECT TO IT LOOK AS THOUGH THEY JUST PULL OFF BUT IVE GAVE THEM A REALLY GOOD TUG AND HAVENT MANAGED TO GET THEM OFF..I DIDNT WANT TO FORCE THEM TOO MUCH INCASE I BROKE THEM. - IS THEIR AN EASIER WAY OF REMOVING THESE OR THE FILTER ITSELF??? IF YOU CAN ANSWER EITHER OR BOTH MY QUERIES THAT WOULD BE VERY MUCH APPRECIATED!!! THANKS GUYS!! :D
  2. Hey, ive had my Ford Focus Estate TDCI 1.6L now for about 3 weeks and its been the same since i got it...that is its very slow... There must be a problem because it takes forever to accelerate and this is most noticable when trying to accelerate from 40-70 going onto a duel carriageway/motorway..which is most annoying and somewhat embarrasing at times. <_< Ive been told it could possibly be a turbo problem/leak, accelerator problem etc. and havent really had it fully checked be a professional yet... Anyone else had/have a similar problem or know of any cost saving solutions?? also perhaps worth noting is that the car doesnt really tend to go above 3500rpm.. in any gear or even in neutral. SOLUTIONS?? ADVICE??
  3. I had a 1.4 petrol Peugeot 206 Quiksilver before this so im pretty new to diesels. I dont know how it was driven before me but it does have 160k on clock so its been pretty well used... No smoke, No knocks, engine sounds as it should but power is just lacking :/
  4. Cheers guys, after some closer inspection I've noticed a pipe that comes from the air intake into the engine has come off!! i put it on and its made a bit of difference but not drastically..i plan to jubilee it on tomorrow so the connection is better and i will service it very soon