• Announcements

    • Stoney871

      Posting in General Chat thread.   11/11/2017

      it has been noted that too many Members are posting messages in the General Chat area instead of the correct Forums. Any messages posted in the General Chat area that are not General Chat will be deleted without warning and offenders may recieve warning points if repeated instances are seen from that Member. There are plenty of different Club areas that encompass 99% of Ford related posts, please select and use the correct one. If anyone is not sure of which area to post something then feel free to P/M myself or other Senior Staff for guidance. The Moderating Staff are having to spend far too much time chasing this problem instead of maintaining the other areas of the forum.


deanom245

Budding Enthusiast
  • Content count

    2
  • Joined

  • Last visited

About deanom245

  • Rank
    Newbie

Profile Information

  • Ford Model
    galaxy 130bhp ghia
  • UK/Ireland Location
    Suffolk
  1. Hi stoney and thanks for the reply but do you no which relays and where they exactly are please cheers dean
  2. Hi all im new here,i have a galaxy o4 130bhp ghia.Its been a fantastic car till yesterday,the front wipers wont work at all as neither will the washer motor.Ive checked all the fuses and they all seem fine.I then thought the motor could have seized up so ive stripped the relevant parts out and removed the motor and arms all in one.After puttin a spanner on the centre nut the motor and arms all seem fine and work as they should.Im now scratchin my head and wondering what next as it definately seems to be a power issue as the wipers or washers wont work,but the rear one still works as it should.Can anyone advise me if there is a relay or relays for the wiper motor please many thanks
  3. Welcome to the Ford forums deanom245 :)