AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


Budding Enthusiast
  • Content count

  • Joined

  • Last visited

About Thiss

  • Rank

Profile Information

  • Ford Model
    Mondeo 2.0TDCi Estate
  • UK/Ireland Location
  1. Thanks for the advice everyone. I took it off tonight and it was well bunged up. Gave it a thorough clean with Gunk and WD40 and put it back together - job done in less than an hour and only one socket lost in the process (somewhere in a snow drift) - quite good for me ! Gave it a quick run up and down the main road and no flashing lights - yippee ! Think I'll treat it to a tin of BG244 anyway, but thankfully I think I may well have fixed it :)
  2. Ok, I'll track some down - don't think Mr Halford sells it so will have to order some. Read that its pretty easy to take the valve off so I'l have a shufty and see how bunged up it is. Have to wait a day or two though - snowing pretty heavy now and no garage :-(
  3. Tks - it was running pukka Ford software (or at least he said it was) - the guy revved the engine and monitored the EGR reading live - said it should close whent revved and was still showing 2-3mm, hence him thinking it was sticking. I've googled the code and scared myself by the number of posts saying they changed this, that and the other and didn't pin down the exact reason - everything from a bunged up fuel filter to new injectors. I'm going on holiday in two weeks time - it has to get me to Gatwick (130 miles) - think its safe to drive if I don't cane it ?
  4. Just found a guy in my village that does it :-) P0251 - something to do with the EGR not closing (or did he say opening) - anyway, he reckons I should remove something and give it a clean.... HELP !
  5. I don't have the means to do that unfortunately - I will need to find a local garage. How much would a main dealer charge to run the diagnostics ?
  6. Hi - just signed up today to try get some advice on this problem - I see it has been mentioned in several posts already but here's my symptons. Car is a 55 plate 2.0 TDCi estate - 70K on clock - mostly round town (5-10 mins drive to work everyday) with more recently some blasts up the motorway to take my little darlings to Uni. Car has always run well and never let me down. Queue the bad weather last week. On way from home, (only a couple of minutes into journey) put foot down to pull away from a junction and car hestitated - like hitting a rev limiter. Tried it again on open road and same again but this time yellow glow plug light flashed and stayed on until I got home. Killed the engine and restared fine - no light Notice same symptoms once of twice again this week. If I build up revs slowly it doesn't have a problem. If I hit the gas it does. Changed the air filter cos it was full of crap. Someone at work suggested a can of redex. Someone else said sell it, before it dies completely... Car is only worth £2-3K so now worth shelling out lots on injectors Any advice please......
  7. Welcome to the Ford forums Thiss :)