• Announcements

    • Stoney871

      Posting in General Chat thread.   11/11/2017

      it has been noted that too many Members are posting messages in the General Chat area instead of the correct Forums. Any messages posted in the General Chat area that are not General Chat will be deleted without warning and offenders may recieve warning points if repeated instances are seen from that Member. There are plenty of different Club areas that encompass 99% of Ford related posts, please select and use the correct one. If anyone is not sure of which area to post something then feel free to P/M myself or other Senior Staff for guidance. The Moderating Staff are having to spend far too much time chasing this problem instead of maintaining the other areas of the forum.


duluxdoggy

Members via FB
  • Content count

    20
  • Joined

  • Last visited

About duluxdoggy

  • Rank
    Member

Contact Methods

  • First Name
    gari

Profile Information

  • Gender*
    Male
  • Ford Model
    Mk2 focus Ghia 1.6 petrol
  • Ford Year
    2006
  • UK/Ireland Location
    Cheshire

Previous Fields

  • Location
    United Kingdom

Recent Profile Visitors

1,069 profile views
  1. Mk2 focus. Clocks dead. Won't start

    Ok. So the guy came round. A small amount of corrosion on the fuse box. Cleaned up still nothing. However he took the cover off the plug that goes into the ic. Found 1 perm live. 3 switched lives. And 4 earth's. He said the ic should be working. Contacted the guy that apparently serviced it and he said he will replace the unit and transfer the immobiliser coding... Lets see how this one goes.
  2. Mk2 focus. Clocks dead. Won't start

    Ok. So had the cluster repaired. Cost £125. But it is still dead. Just tested the socket and no live going to the unit. Got electrician coming tomorrow to try. He thinks maybe control unit failure....
  3. Mk2 focus. Clocks dead. Won't start

    Just checked. No immobiliser light. All fuses good. Local garage just told me it will be the clocks... Without a shadow of doubt...
  4. Mk2 focus. Clocks dead. Won't start

    Will take a look at that. I dont think the immobiliser light is flashing at all now tho. I checked for that when it wouldn't start again. Incase transponder broke or something along those lines.
  5. I opened all the windows with the fob on way to car. Started the engine, turned on the ac and grabbed my phone to set music. I then went to drive off and noticed that the clocks are dead. Including the lcd display. Which was working prior. So I turned the engine off and tried to restart.... Nothing. No clicks. Electric Windows still work. As is the locking. But windows wouldn't close with the fob long press. I had to go get the bike out (at least it's sunny) The guys in work suggest a main fuse. Anyone had this before? Or any ideas what could be wrong?
  6. Suspect Clutch, Only In 5/6Th Gears

    this. but not really hard acceleration, but it is making it a lot harder to overtake anything, i gfet full positive drive under very hard acceleration in the first 4 gears tho, and that is what is baffling me,
  7. Suspect Clutch, Only In 5/6Th Gears

    no, when accelerating in 5/6 from about 2k rpm (not flat out, but moderate throttle) the reps start to climb, but the speed gradually inccreases, but when i back off the throttle, the revs drop back to what would be expected for that given speed
  8. Suspect Clutch, Only In 5/6Th Gears

    i can see your point, but given the fact that im already used to the fixed setup, and it is £500 instead of £700 to fix it i cant justify the extra cost, but the main thing im asking is why is it only slipping in the top 2 gears
  9. i bought my 2006 2.0 tdci 130 (6sp) mondeo 18 months ago, with history including new clutch, at 79,000 miles reading thru the invoice, and after phoning the garage that fitted it, they fitted a single mass flywheel kit, it is now on 102,000 miles and it has started slipping, but only in the top two gears, and when it slips the cruise control gets disengaged automaticly 1. should a kit wear out in 20,000 miles, maybe a little bit of spirited driving on the odd occasion ( ok, maybe a little more often than that!!) no towing at all, 2. is it the clutch at all, could ther be any other problems causing this. and my 3rd question was should i fit a single mass kit, and what are the drawbacks of it, but since i started typing this post i found out i already have one.... so i guess i dont have to worry about that
  10. hi, i bought my mk3 mondeo 2.0 tdci 130 about 2 months ago, people keep telling me as i power away from em there is a LOT of black coming out of the exhaust. mainly at low revs it would seem, im told these have injector issues, regularly needing replacement costing a lot. this is not rly an option, i have been advised to get some redex, anyone any experience of this? and will the redex make much difference?
  11. Sony 6Cd Head Unit

    hi. sorry foe delayed reply, i have been in work, i have removed the unit again and taken a side by side photo, as you can see there is a massive difference in the two units, is it even possible to use a normal unit in the ghia car??? i very much doubt that ford would use a completely different dash layout, im getting fed up with this issue, may just get a cheap adapter kit and fit me trusty kenwood single din cd player. i have been avoiding this as i wanted to keep the remote on steering column
  12. Sony 6Cd Head Unit

    this is the ebay listing i bought it from, as you can see it is wider at the top, but the angle is different 0 i thought i was buying a mondeo unit
  13. Sony 6Cd Head Unit

    ok, so i remove the head unit, and it has already had an attempted repair job. but either way, its goosed. so i go on ebay and buy a ford 6000cd head unit, but, i just ent to install it and it doesnt fit... see photo. any idea what ford stereo will work??
  14. Sony 6Cd Head Unit

    i will look into this later, i need to get some keys to be able to remove the unit. and if i need to replace the unit, im not going to, i dont have any music on cd anyways. i just use spotify. only bouhg a cheap cd to test it! kinda wish i didnt now
  15. Sony 6Cd Head Unit

    no, the eject and load buttons dont do anything, it wont go on cd mode, i am assuming that is why they dont do anything, i have no way of knowing if ther is a disc inside already or not.