AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


duluxdoggy

Members via FB
  • Content count

    15
  • Joined

  • Last visited

About duluxdoggy

  • Rank
    Member

Contact Methods

  • First Name gari

Profile Information

  • Gender* Male
  • Ford Model Mondeo 2L TDCI 130, ghia x
  • Ford Year 2007
  • UK/Ireland Location Cheshire
  • Annual Mileage 5001 to 10,000

Previous Fields

  • Location United Kingdom
  1. Suspect Clutch, Only In 5/6Th Gears

    this. but not really hard acceleration, but it is making it a lot harder to overtake anything, i gfet full positive drive under very hard acceleration in the first 4 gears tho, and that is what is baffling me,
  2. Suspect Clutch, Only In 5/6Th Gears

    no, when accelerating in 5/6 from about 2k rpm (not flat out, but moderate throttle) the reps start to climb, but the speed gradually inccreases, but when i back off the throttle, the revs drop back to what would be expected for that given speed
  3. Suspect Clutch, Only In 5/6Th Gears

    i can see your point, but given the fact that im already used to the fixed setup, and it is £500 instead of £700 to fix it i cant justify the extra cost, but the main thing im asking is why is it only slipping in the top 2 gears
  4. i bought my 2006 2.0 tdci 130 (6sp) mondeo 18 months ago, with history including new clutch, at 79,000 miles reading thru the invoice, and after phoning the garage that fitted it, they fitted a single mass flywheel kit, it is now on 102,000 miles and it has started slipping, but only in the top two gears, and when it slips the cruise control gets disengaged automaticly 1. should a kit wear out in 20,000 miles, maybe a little bit of spirited driving on the odd occasion ( ok, maybe a little more often than that!!) no towing at all, 2. is it the clutch at all, could ther be any other problems causing this. and my 3rd question was should i fit a single mass kit, and what are the drawbacks of it, but since i started typing this post i found out i already have one.... so i guess i dont have to worry about that
  5. hi, i bought my mk3 mondeo 2.0 tdci 130 about 2 months ago, people keep telling me as i power away from em there is a LOT of black coming out of the exhaust. mainly at low revs it would seem, im told these have injector issues, regularly needing replacement costing a lot. this is not rly an option, i have been advised to get some redex, anyone any experience of this? and will the redex make much difference?
  6. Sony 6Cd Head Unit

    hi. sorry foe delayed reply, i have been in work, i have removed the unit again and taken a side by side photo, as you can see there is a massive difference in the two units, is it even possible to use a normal unit in the ghia car??? i very much doubt that ford would use a completely different dash layout, im getting fed up with this issue, may just get a cheap adapter kit and fit me trusty kenwood single din cd player. i have been avoiding this as i wanted to keep the remote on steering column
  7. Sony 6Cd Head Unit

    this is the ebay listing i bought it from, as you can see it is wider at the top, but the angle is different 0 i thought i was buying a mondeo unit
  8. Sony 6Cd Head Unit

    ok, so i remove the head unit, and it has already had an attempted repair job. but either way, its goosed. so i go on ebay and buy a ford 6000cd head unit, but, i just ent to install it and it doesnt fit... see photo. any idea what ford stereo will work??
  9. Sony 6Cd Head Unit

    i will look into this later, i need to get some keys to be able to remove the unit. and if i need to replace the unit, im not going to, i dont have any music on cd anyways. i just use spotify. only bouhg a cheap cd to test it! kinda wish i didnt now
  10. Sony 6Cd Head Unit

    no, the eject and load buttons dont do anything, it wont go on cd mode, i am assuming that is why they dont do anything, i have no way of knowing if ther is a disc inside already or not.
  11. Sony 6Cd Head Unit

    hi, i bought a 2007 mondeo ghia x today. the radio sounds ace, however, when i press the cd/aux button it goes to aux, and stays on aux. i cant make it go onto cd mode. the aux port in the glove box works fine, and with most of my music being on my phone anyways its not the end of the world. but i would like to fix this, if poss. is my head unit broke? or am i missing something, have tried every button on it.
  12. Front Wipers

    fixed, turned out it was the relay. £24 +vat just glad it will now get through the mot, was panicking a bit
  13. Front Wipers

    im waiting to hearr back from my local ford dealer now. he is not sure of what relay i need, he thinks it is £60... the other problem is that i need to un-bolt the fuse box to get access to it but i dont have a socket that small (grrr)
  14. Front Wipers

    hi, if i move the switch to the stopped position during the cycle the wipers just stop wherever they are. if i press the lever down to initiate a single pass of the blades i have to hold it down untill the blades are 'home'
  15. Front Wipers

    hi, i have my 02 focus TDDi,m i put it in for the mot last week and one of the things it failed on was the wipers not returning to the home position after i turn turn them off. i have owned the car a year almost and it came witth a 12 month mot. so i dont know how they passed it last time, so i have replaced the wiper switch/stalk. no change, replaced the motor with one from a breakers, no change, unlikely to have 2 parts with the same fault surely? im kinda stuck now due to my cars mot expiring in 3 days... please help. is it a fuse? cant find my Haynes.