Ford Owners Club - Ford Forums Messages

Club Announcements

Discounted Car Insurance: Owners Club insurance could save you money on your car insurance. Get a quote

Review your Ford: Help others when it comes to buying a car like yours and review your Ford now

Ford Car Parts: View All ford car parts by category. Look for Ford Car Parts now!


Birt82

Budding Enthusiast
  • Content count

    6
  • Joined

  • Last visited

About Birt82

  • Rank
    Newbie

Profile Information

  • Ford Model
    Mondeo tdci
  • UK/Ireland Location
    Cheshire
  1. Just thought I would update this, it was the flywheel, changed for luk dual mass, car runs perfect with no vibrations or anything. Cheers all.
  2. The more and more I look into it etc, the more I feel that the flywheel is an issue somewhere.
  3. What was yours doing pal? Exactly, any lights on etc etc?
  4. Hi there, thanks for the responses, I have brand new autel diagnostic kit, no fault codes present. The car starts and runs fine, will idle all day long, and is fine until the rpm is raised and them released from say 3000rpm. Then it stops. Surely it would play up otherwise if it was injectors? Has anyone else fit a dmf delete? Could it be anything to do with that? Cheers Steve
  5. Hi all, new here, just entered ford ownership and having trouble.......... Full story : 2005 mondeo tdci 130 70k Bought with a noisy dual mass flywheel, I used the car for 3-4 days and it was fine, dual mass rattled and starter was goosed, so parked it up until I could do it. So on Friday, I fitted a dual mass delete, so solid flywheel, clutch and slave cylinder, new starter motor. No problem. During fitting we noticed the crank sensor had been rubbed, but I felt it was ok before so should be ok now. Wrong.... I serviced the car, fram filters, oil, air, pollen, fuel etc. On the drive home I came to a junction and it just cut dead, started up instantly again. Did it 4 or 5 times, I just presumed the sensor was knackered, so replaced it. No different at all. So if you sit and rev the car to 3-3.5000rpm and let off it stops, or if you drive and come to a junction etc it will do the same. No lights on etc, anyone got any ideas?? Fed up with it already! :( Cheers Steve Serviced, oil, filter, air filter, fuel filter (fram parts) used. On the d
  6. Welcome to the Ford forums Birt82 :)