Members via Twitter
  • Content count

  • Joined

  • Last visited

About RenaiJay

  • Rank

Profile Information

  • Ford Model
    Fiesta Zetec
  • UK/Ireland Location
  1. @TheRavengame Is this true? The ps3 version has been cancelled???

  2. Well as luck would have it the mechanic from the garage (family friend) just popped over to have a listen as the car has been stood all day. It did it for about 15 seconds then disappeared, he's convinced its the power steering belt which is self tensioning and has said not to worry as it probably wont do it once the weather picks up a bit. The belt I supplied myself (Gates belt) and they're willing to replace it with another one for £10 if I want them to but he's adament its a waste of money due to the circumstances it does it and that its really nothing to worry about. He also said its not really classed as a squeak and is more of a very intermittent chirp! Does all this sound right? Should I bother getting it changed if this is the case?
  3. Probably a silly question but would this be the Timing belt / Power steering belt or Aux belt that's slipping? I forgot to mention too but it isn't loud either. If the door is shut then you can't hear it.....only if the door or window is open.
  4. Hi people, Sorry for my first post being a question but I was recommended to try here to get some advice. I have a MK6.5 Ford Fiesta Zetec (1.4) and a couple of months ago when having a service my local mechanic advised that the Cambelt could probably do with being changed too. The car is a 2006 with just over 50k on the clock. In all fairness he did pull the camcover back and show me the signs of the belt on its way out. He also showed me a small chunk missing off the power steering belt and said it would probably be ok but I figured for the cost of £12 (he fitted it for free) it was worth the piece of mind. The Aux Belt looked fine so we decided to leave that one be. Cambelt, Tensioner and Power Steering belt were replaced but I have a slight worry that I figured I'd put out here. If the car has been stood for over 12 hours, especially when damp, for around the first 10-20 seconds from starting there is a slight squeek squeek sound. It disappears and then never comes back. I can use the car, leave it stood for 6 hours and it won't do it again until its been stood for over 12 hours overnight. It does increase with revs but tends to drop off on higher revs then never comes back. I went back to the garage and was told that its more than likely just the new belt and they sprayed a small amount of white grease on it which hasn't really made any difference. Its also very difficult for them to diagnose as unless I leave the car with them overnight theres no chance of them hearing it. I'm guessing its nothing major as the car has since done 7k miles without a hiccup apart from those first 10-30 seconds. So there you have it...sorry for the essay.....what are peoples views?
  5. Welcome to the Ford forums RenaiJay :)