Ford Owners Club - Ford Forums Messages

Club Announcements

Ford Fair 2016: Tickets and stand passes are now available to purchase. More info here.

Review your Ford: Help others when it comes to buying a car like yours and review your Ford now

Ford Car Parts: View All ford car parts by category. Look for Ford Car Parts now!

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


HFA2013

Budding Enthusiast
  • Content count

    3
  • Joined

  • Last visited

About HFA2013

  • Rank
    Newbie

Profile Information

  • Ford Model Focus
  • UK/Ireland Location Surrey
  1. 2007 1.6 Focus Climate

    I think I will have to, I'm stumpt. On watching the engine temp from the led display it goes from between 90-100c then suddenly dropped to 13c then 0c which caused the fan to come on and put the engine warning light back on.
  2. 2007 1.6 Focus Climate

    Thanks for the quick reply gents, just checked and there is pressure in the hose. Also had checked to find any faults by holding the reset button for miles etc when the ignition is off and then turning back on which has shown no faults. the only thing that has changed is the engine warning light has now disappeared. I thought it may be a faulty thermometer. Just trying to rule out a few issues before paying a lot of money at my local dealer.
  3. 2007 1.6 Focus Climate

    Hi boys and girls, I'm pretty sure this will be the wrong place to comment and there is already a topic out there but this is my first car forum visit ever so I do apologise. My problem is I have a 07 focus with to me ( no mechanical knowledge ) a very strange problem, the issue is my car will get up to temp bang on in the middle of temp gauge it will then drop to 60c and the electric fan begins to run constantly. I have checked all fluid levels and checked for leaks etc and I yet to find any. The car will then blow out cold air despite being on the hottest setting and no change of temp gauge after 30 minutes worth of driving. If I could please get some help or some advise from someone who has had this problem or knows about it then please don't hesitate to reply here or even email. Thanks for your help Harry
  4. Welcome to the Ford forums HFA2013 :)