Members via FB
  • Content count

  • Joined

  • Last visited

About e11even

  • Rank

Contact Methods

  • First Name

Profile Information

  • Gender*
  • Ford Model
  • Ford Year
  • UK/Ireland Location
  • Annual Mileage
    5001 to 10,000

Previous Fields

  • Location
    South Africa
  1. Thanks James, will try that :)
  2. Hi, We've had heavy rains here in Cape Town and this weekend my fiancee's brother borrowed the Ka. He encountered a car stuck in water so had to reverse to get around it. At this stage the exhaust pipe was underwater. Now the engine chugs. What is the problem? Is there a way water could've gotten into the cylinders? The puddle was pretty deep. Any advice would be greatly appreciated (not including smacking the fiancee's brother around).
  3. Hi Stef, Took it in and once up on the lift we spotted the right rear wheel was loose! Wheel bearing f'd. Replaced that and now all good. ABS light also off. Thanks for the feedback though, without this forum I may not have deemed it serious enough to have checked out this promptly and the wheel could have come off! And this forum would've had one less member. In essence Ford Owners Club saved my life. Cheers, L
  4. Thanks Stef and Bruce. Will have that looked at. Is it something I could replace myself?
  5. Ok, the brake pads are fine (not even halfway worn). And the grinding/screeching noise happened on a bumpy uphill yesterday when no brakes were being applied. And the car feels like its floating around on its axles, and when you steer it takes a while to respond... what could this be???
  6. Fortunately, we've had no further problems since replacing the battery :)
  7. Thanks Steve. Will have them seen to today.
  8. Could the brake pads be worn out?
  9. Hi, My ABS warning light came on a couple days ago. Its still on. I haven't tested the ABS but today when I braked to stop on a downhill the car's dipped sharply and I heard a grinding noise and felt it through the pedal. Any ideas?
  10. Thanks Andy. Will have to have it checked out...
  11. Thanks Dave
  12. Hi, My fiancee owns a 2006 Ford Ka and she's been having battery problems. We replaced her battery and it starts fine now, but the alternator light comes on every now and then. Any ideas why this could be happening? I understand it could be any number of problems, including simply a problem with the alternator but maybe this is a common problem with these cars? I am taking it in to an auto electrician later today but was hoping to get some input from the members of this forum. Any advice or feedback would be greatly appreciated! Cheers, Lars
  13. Hi, I am joining this forum on behalf of my fiancee who drives a Ford Ka. Its a great little car and she's had very few problems with it. All-round smashing little racer. I intend to post questions relating to it so I'm hoping to get some valuable advice etc. Cheers! Lars (from South Africa)
  14. Welcome to the Ford forums e11even :)