• Announcements

    • Stoney871

      Posting in General Chat thread.   11/11/2017

      it has been noted that too many Members are posting messages in the General Chat area instead of the correct Forums. Any messages posted in the General Chat area that are not General Chat will be deleted without warning and offenders may recieve warning points if repeated instances are seen from that Member. There are plenty of different Club areas that encompass 99% of Ford related posts, please select and use the correct one. If anyone is not sure of which area to post something then feel free to P/M myself or other Senior Staff for guidance. The Moderating Staff are having to spend far too much time chasing this problem instead of maintaining the other areas of the forum.


PollyP

Budding Enthusiast
  • Content count

    3
  • Joined

  • Last visited

About PollyP

  • Rank
    Newbie

Profile Information

  • Ford Model
    Fiesta 2009 Diesel titanium
  • UK/Ireland Location
    Bedfordshire
  1. 2009 Fiesta Zetec Electrical Problem?

    Hi Sam No haven't a clue what causes it, it appears very common and could just be cheap/bad components Possibly a 'dry solder joint' but so many people seem to have had the same problem, I'm surprised Ford hasn't had to do some recall. Polly
  2. 2009 Fiesta Zetec Electrical Problem?

    Hi Sam Thanks for getting back. Whilst researching the problem I came across a 2009 forum on this fault. They solved the problem by pulling and re-inserting a fuse from the passenger fuse box. 7.5 FUSE NUMBER 20 (FOR MULTI-FUNCTION DISPLAY ETC) see page 107 onwards in hand book. I've taken that out and put it back in and problem solved (hopefully for good) I can only assume your flat battery and jump start had the same effect, but if you need to do it again ,empty your glove box, squeeze the sides of the glovebox inwards to release and drop the glove box out of the way and then the fuses are clearly accessible.. Hopefully we won't need to do it again. Regards Polly
  3. 2009 Fiesta Zetec Electrical Problem?

    My Ford Fiesta 2009 Titanium Diesel has just developed exactly the same problem. Samster have you managed to get this fixed yet? Was it a general fault caused by damp weather and does anybody now if this is a common design fault likely to be subject to a Ford recall? Thanks Polly
  4. Welcome to the Ford forums PollyP :)