durv Cymru

Budding Enthusiast
  • Content count

  • Joined

  • Last visited

About durv Cymru

  • Rank

Profile Information

  • Ford Model
    Focus 1.6 TDCI
  • UK/Ireland Location
  1. Hi Basil I too had a limp mode problem when accelerating. The red 'cog' engine stop lamp would light up rather than the amber engine management light. My code reader is unable to read the faults associated with the red 'cog' only the EML when illuminated. Worth going to the garage to read the cached fault code/s then tackling the cause if necessary. The diagnosis on mine was EGR valve which I've subsequently blanked off. Best of luck
  2. Had similar when the switch became full of water. Had to swap it for new
  3. I thought I'd just post my recent experiences regarding the pesky EGR valve on my 55 1.6 tdci focus. Had to act following numerous and increasing limp mode activations and associated red cog illuminations. Spent a few evenings on this forum which convinced me that blanking it off was the way to go. (thanks to all the expert contributions) First tried unplugging the EGR valve with very positive results although it brought the engine MIL light on after the 3rd start. Bought a stainless steel plate off flea bay for the price of a pint and fitted it on Saturday. I only removed the engine cover bracket and pushed the fuel filter out the way 6 bolts in total. Found no need to remove the plastic scuttle or wipers. Used the wife's small mirror to see the 2 bolts on the EGR and slacken them off. Slid the plate manifold side of the gasket and tightened it all up etc. Including re-attaching the plug and restting the MIL it only took about 30 minutes. Happy to report 250 miles with no limp mode and no engine lights on. If you're in any doubt, give it a go. It's not challenging and the benefits are immediate. All the best
  4. Quick update...MIL now illuminated but still running well. Looks like the blank needs to go on after all!
  5. Hi bikerjake My first post here too...got 55 plate 1.6 TDCI with only 70k on clock. Had all the symptoms you describe except turbo issues so far. DPF was the major expense last year but now deleted and remapped. Immediate improvement but still lumpy delivery and vibrating around 1500 revs plus going into limp every time the throttle is pressed! Decided to blank off the EGR valve and the blanking plate arrived yesterday. Just thought I'd try disconnecting it before getting tools out and went for test drive. Happy to report no dash lights and a better feel to power delivery across all gears. Also much reduced vibration. Early days and may yet be disappointed but free to try and only a 2 minute job. Fingers crossed G
  6. Welcome to the Ford forums durv Cymru :)