AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


kvkev

Budding Enthusiast
  • Content count

    4
  • Joined

  • Last visited

About kvkev

  • Rank
    Newbie

Contact Methods

  • First Name kevin

Profile Information

  • Gender* Male
  • Ford Model fiesta mk5
  • Ford Year 2002
  • UK/Ireland Location Warwickshire
  • Annual Mileage 0 to 5000
  1. Heater And Gauge Problem

    ok cool, thanks all
  2. Heater And Gauge Problem

    ok, thankyou, what did they charge for this update? dont want to get ripped off.
  3. Heater And Gauge Problem

    oh and its a 1.4 diesel.
  4. hi all, i have two problems the first is after a mile or so i loose my mph reading on the dashboard, then a little while after i loose my digital milage reading, after this everytime i change gear it sounds like im riding the clutch, until ive turned off the ignition for a few hours then its fine for while and the process starts again, i think it could be the speedo sensor, am i right? the second is my heater blows cold air but the temp gauge is reading normal and when the above problem happens the temp gauge rises instantly to just under the red but still without hot air coming through, but when the above problem doesnt happen i do get hot air, could this be caused by the thermostat? please help winter is here and its bleeding cold in the mornings, many thanks.