Mark-387

Budding Enthusiast
  • Content count

    5
  • Joined

  • Last visited

About Mark-387

  • Rank
    Newbie

Contact Methods

  • First Name
    Mark

Profile Information

  • Ford Model
    Focus
  • Ford Year
    2002
  • UK/Ireland Location
    Hampshire
  • Annual Mileage
    0 to 5000

Recent Profile Visitors

864 profile views
  1. Hello everyone! My dads got a automatic fusion. He said on the way home from work which is a 5min drive the cars making a funny noise. I had a look and it's making a clonking noise and a slight squeak as well under steering. Defo sounds like its coming from the steering rack. Power steering fluid is all good but he has been having a coolent leak as well I don't know if its connected. Any help would be appreciated. Cheers mark
  2. Ah ok I've managed to to the old coil pack back on its running better but still lumpy. Error code was p0304 the other one was n/a :(
  3. Hi guys needing some help I've got a focus 53 plate it's been running a bit poorly the engine management light came on when I went to the shop (2min drive) as I was on the way back the eml was flashing. I got my code reader out it had 2 codes one was not applicable so I don't know and the other was miss fire. So I've changed the following: Coil pack, ht leads, and spark plugs. But now runs really bad nearly cutting out. Has anyone got any ideas at all I'm thinking injector or lambda sensor. Any ideas would be a big help cheers mark.
  4. Welcome to the Ford forums Mark-387 :)