Budding Enthusiast
  • Content count

  • Joined

  • Last visited

About mgracer

  • Rank

Contact Methods

  • First Name

Profile Information

  • Ford Model
  • Ford Year
  • UK/Ireland Location
  • Annual Mileage
    10,001 to 15,000
  1. i had a\someone come round with testing equipment, turns out the ecu is dead, he said he is getting no coms from the ecu and the fuel pump is constantly running, after checking he found the ecu was soaking from water leaking into the car and pooling on the ecu's plug, which inevitably killed it :-(
  2. weve got someone coming down tomo to diagnose it, gonna cost 30 squid, worth it just to see then ill decide to scrap it depending on what the problem is, ill let you know and thanks anyway
  3. yep, overnight infact
  4. the light next to the clock does absolutly nothing, its completely dead, all the fuses both in the car and engine bay have been checked and are all fine. its as if the immobilizer has just died. id thought id check the leads on the ecu as from what i have found its both ecu and immobiliser in one unit. but if they are bolted down then is there any point?, i have located the ecu in the right hand side of the door above the kick plate, also theres this wierd looking red button thing there, ive tried turning the car over with the button pushed down and pulled up, can anyone explain what it is? it doesnt seem to do anything . the ecu is firmly jammed right up the dash and the only way i can see of getting to it is removing the dash, hence why its easier to scrap it, i aint wasting my time , btw its a mk4
  5. also does any one know if i can use an ecu from a ka to use with the same engine in a fiesta?
  6. no, nothing from under the bonnet, i have tried bumping it and nothing, i can hear the fuel pump but the immobilizer light does not come on at all, i have got a ka that i am breaking for spares so i took they key and sensor from the ka and installed them onto the fiesta and still nothing but when i done the same to the ka the immobilizer light was flashing like mad, so im pretty sure the immobilizer is nakered. all i need is to find where it is and check the leads
  7. the engine wont start (dead at key) but the ignition lights are turning on, the drivers door hinges are worn and we have to slam the door to close, after a few slams i thing the ecu has had enough and either died or partially disconnected, the immobilizer light never comes on so my thoughts are the constant slamming of the door has dislodged the leads connecting the ecu, but i cant find it anywhere
  8. Welcome to the Ford forums mgracer :)