Fenlander

Budding Enthusiast
  • Content count

    2
  • Joined

  • Last visited

About Fenlander

  • Rank
    Newbie

Contact Methods

  • First Name
    Andy

Profile Information

  • Ford Model
    Focus
  • Ford Year
    2007
  • UK/Ireland Location
    Gwynedd
  • Annual Mileage
    10,001 to 15,000
  1. Hi thanks for the reply. The service history with it shows that it had all filters changed in August. It's a bit of a puzzle no problem with it at all today even after its been sitting on the drive all weekend not going anywhere. It seems ok if it reaches temperature on the previous journey before stopping, if it doesn't that's when my problems appear to start the next day.
  2. I've got a 2007 mk2 focus 1.8 diesel. I'm having problems starting it after short journeys. If I travel say a couple of miles and leave it for several hours it won't start first time. It usually almost starts and then cuts out and then takes quite a bit of cranking and several attempts. Travel a couple of short journeys and leave it overnight and it's a complete bugger to start the next day. No problem starting it at all after longer journeys. I've had the glow plugs replaced and the egr valve cleaned out as the car was going into limp, turns out it was quite choked. Also cleaned out the fuel system with some additive and treated the car to some premium diesel at the last fill up but the problem persists with a cold start after short trips. It's been to the garage and diagnostics have not picked up anything, anybody come across this before or have any ideas? I only got the car in November last year and had the turbo replaced in December as the oil feed pipes failed, could it be linked?
  3. Welcome to the Ford forums Fenlander :)