AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


New Member
  • Content count

  • Joined

  • Last visited

About Hadden

  • Rank

Contact Methods

  • First Name

Profile Information

  • Ford Model
    Frd mondeo tdci
  • Ford Year
  • UK/Ireland Location
  • Annual Mileage
    0 to 5000
  1. Hi to this forum and new to fords.i bought a 04 plate saloon mondeo 2ltr tdci on Thursday.been in and out of it loads since and everything has been spot when I turned the lights on the rear lights came on and so did the brake I nipped to halfords last night and bought the correct bulbs.i changed one,started the car to check it worked properly and all was sound.i then changed the second bulb but the car just made a fast ticking noise like it had a low battery.a halfords man checked the battery and said it was fine.i tried to bump and jump start it and nothing.when I turn the key to position 3 the red light on the clock flashes really fast.i spoke to a few blokes and they said its the I took the key to a key shop this morning who put it in a machine and said its reading the chip fine so it must be the car.just to make sure it wasn't the starter motor I took out the starter relay and bridged it.i can here the starter motor spinning but it just won't have I got a starter motor problem or immobiliser?or both?any help would be fantastic.cheers
  2. Welcome to the Ford forums Hadden :)