AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


Budding Enthusiast
  • Content count

  • Joined

  • Last visited

About Freek_Ba

  • Rank

Contact Methods

  • First Name

Profile Information

  • Ford Model
    2001 Fiesta 1.6 Zetec
  • Ford Year
  • UK/Ireland Location
  • Annual Mileage
    0 to 5000
  1. We have got the engine running but it is not on full power. I can see that there is a problem with the ignition. When we open the throttle, the ignition goes the wrong way (20 degrees later in stead of earlier). I hope you understand what i mean with this. We have reduced the cables to the exact minimum we need. Does anyone know what the problem could be?
  2. Hello everybody, I am a last year engeneering student from Belgium and for my thesis I am working on a 2001 1.6 Zetec engine. I took the engine out of a side damaged Fiesta and built a frame to hold the engine (I'll post pictures later). The engine wil get mounted on a Superflow testing module (see picture). Wen i'll have it working on the original ECU, I will change the ECU for a programmable one based on MegaSquirt. Guessing I will bump on some problems I have started this topic. I hope you guys can help me. My first question: Why are there 2 lambda-sensors? There is one before the kat (a green fiche) and one behind it (blue fiche). This will not give any problems with the original ECU, but it will in the new one where I only need one. Greeting, Freek.
  3. Welcome to the Ford forums Freek_Ba :)