Ford Owners Club - Ford Forums Messages

Club Announcements

Ford Fair 2016: Tickets and stand passes are now available to purchase. More info here.

Review your Ford: Help others when it comes to buying a car like yours and review your Ford now

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


Beverley7285

Budding Enthusiast
  • Content count

    3
  • Joined

  • Last visited

About Beverley7285

  • Rank
    Newbie

Contact Methods

  • First Name Beverley

Profile Information

  • Ford Model Focus Ghia diesel
  • Ford Year 2007
  • UK/Ireland Location Devon
  • Annual Mileage 5001 to 10,000
  1. Battery Keeps Going Flat

    Thanks guys. It was serviced in September so assuming the oil is ok. I will check what battery they supplied but I am with you I feel it is the alternator. I have said this to the garage but they assure me they have tested it. I don't know the vault age of the battery when it's not running as I can drive a car but am clueless to the running of them being a woman! Appreciate your input and will talk to the mechanic today and let you know. Mind you they were the ones who disconnected my radio because they said it was coming on at night and draining the battery! Have been taking it back to them as they fitted the alternator and they are a big reputable garage and haven't charged me for the times it has been backwards and forwards. May be time to take it to the ford garage!
  2. Battery Keeps Going Flat

    Ah bless you for your replies! I didn't need a new battery in the first place as the AA guy said it was fine when it broke down ( one of many more to come!) so I haven't even paid for it yet. It takes a while ticking over before it starts and the smoke bellowing out of the exhaust is a worry? I have owned it since brand new and was fine before the service. It also clicks in the glove compartment when ticking over so all a bit confusing
  3. Battery Keeps Going Flat

    Hi can anyone please help me? My ford focus Ghia diesel 57 plate was serviced in September. Since then I have had nothing but problems. A week later all of the electrics went so they took it back and replaced the alternator. I then had trouble starting it as air kept getting in the system so they sealed the oil filter which seemed to sort that problem out. Then it was completely dead starting so they replaced the battery. After a few weeks it took a lot of turning over to get it started and this followed by clicking in the glove box. Then it was completely dead so they took it back and have now returned it with the radio disconnected as they say that it is coming on at night and draining the battery!! That was on Thursday but on Saturday I had trouble starting, clicking in the glove box, the temperature illumination turned into a line not a number and grey smoke poured out of the exhaust. I don't know what to do as the garage say there is nothing wrong with it but it seems to be an electrical fault? surely the smoke is something to do with the oil? This was replaced along with the filter in September so this should not be a problem? Would really appreciate if anyone can shed light on this problem for me as I am a letting agent and need my car for work so it has really been an issue and I just want it sorted Thank you
  4. Welcome to the Ford forums Beverley7285 :)