Ford Owners Club - Ford Forums Messages

Club Announcements

Discounted Car Insurance: Owners Club insurance could save you money on your car insurance. Get a quote

Review your Ford: Help others when it comes to buying a car like yours and review your Ford now

Ford Car Parts: View All ford car parts by category. Look for Ford Car Parts now!


jackrod6

Budding Enthusiast
  • Content count

    13
  • Joined

  • Last visited

About jackrod6

  • Rank
    Member

Contact Methods

  • First Name
    jack

Profile Information

  • Gender*
    Male
  • Ford Model
    focus
  • Ford Year
    2003
  • UK/Ireland Location
    Swansea
  • Annual Mileage
    5001 to 10,000
  • Interests
    Classic Cars
    General Automotive
    Motorsport & Racing
    Car Modification
    Travel
    Road Trips
    Computers & Electronics
    Sports & Leisure
  1. so my car has been idleing poorly and the MPG has been low recently, ive been narrowing it down and while under the bonnet today cleaning my IAC valve i noticed a clicking sound and found it to be my A/C compressor clutch engaging and dissengaging a couple of times per minute on its own! i filmed it and put it on youtube to give you all a better idea of what im talking about ...http://youtu.be/xDccAus3aM8 <<<<<< thats the link! anyone know why this is happening, how to fix it and how to stop it happening again? thanks, jack! BTW my car is a focus ink 1.6 53 plate (zetec se engine)
  2. I can only assume it's the original as there was no receipts to say otherwise when I bought her Sent from my iPhone using Ford OC
  3. So I've read that cambelt change is due on the Zetec engines at about 80-100k miles. Mine is 53 plate and has done 90,000 miles, realistically when should I be looking to change mine? Thanks, jack. Sent from my iPhone using Ford OC
  4. Thanks for the reply, that thread basically just explained what I already suspected. I guess there's no direct reason as to why my car isn't getting great MPG, probably just a combination of the things in the other thread. Thanks for the help! Sent from my iPhone using Ford OC
  5. So my 53 plate focus ink 1.6 with a 55 Ltr tank has done 350 miles from a full tank of tesco momentum petrol. This averages at 30 MPG which is 10 less than I've read is average! Anyone else with the same or the similar 1.6 Zetec got any figures of what they get? Also anyone know why mine might be achieving less? Thanks. Sent from my iPhone using Ford OC
  6. the light on the switch comes on when pressed, would that mean the fuse is faultless? will check the connection tho, thanks!
  7. there is one called 'forte' which is apparently really good, never used it myself tho so just going on what ive heard.
  8. hi guys, my mk1 53 plate focus ink drivers heated leather seat has stopped working, the passanger side one still works tho. any ideas what it could be? thanks, jack.
  9. Ok that makes perfect sense, thanks for your help guys! Sent from my iPhone using Ford OC
  10. Cheers for reply, it's barely using any oil which I thought was strange after seeing the smoke but since noticing I haven't seen the blue smoke for a few days! Guess it can't be anything to worry about? Let me know how you get on mate. Jack Sent from my iPhone using Ford OC
  11. hi guys, my 53 plate focus ink (zetec 1.6) was giving off some 'blue' smoke after a cold start a few mornings ago, i think the likely cause is my valve seals leaking oil? can anyone tell me more about this? or any other possible causes or any experience or advice with this? other than the 'blue smoke' the car is in relativly great condition. the only other thing ive pondered on is after a cold start also the idle seems to be slightly higher than after the engine has heated up and the rev clock seems to go up and down slightly above and below 1000RPM a few times. the car has done around 80,000 miles if thats relevant, thanks.
  12. hi guys, my 53 plate focus ink (zetec 1.6) was giving off some 'blue' smoke after a cold start a few mornings ago, i think the likely cause is my valve seals leaking oil? can anyone tell me more about this? or any other possible causes or any experience or advice with this? other than the 'blue smoke' the car is in relativly great condition. the only other thing ive pondered on is after a cold start also the idle seems to be slightly higher than after the engine has heated up and the rev clock seems to go up and down slightly above and below 1000RPM a few times. the car has done around 80,000 miles if thats relevant, thanks.
  13. hey guys! joined last year but only now logging on. just finding my feet at the moment ;)
  14. Welcome to the Ford forums jackrod6 :)