• Announcements

    • Stoney871

      Posting in General Chat thread.   11/11/2017

      it has been noted that too many Members are posting messages in the General Chat area instead of the correct Forums. Any messages posted in the General Chat area that are not General Chat will be deleted without warning and offenders may recieve warning points if repeated instances are seen from that Member. There are plenty of different Club areas that encompass 99% of Ford related posts, please select and use the correct one. If anyone is not sure of which area to post something then feel free to P/M myself or other Senior Staff for guidance. The Moderating Staff are having to spend far too much time chasing this problem instead of maintaining the other areas of the forum.


bunny

Budding Enthusiast
  • Content count

    2
  • Joined

  • Last visited

About bunny

  • Rank
    Newbie

Contact Methods

  • First Name
    George

Profile Information

  • Ford Model
    Escort Finesse 1.6
  • Ford Year
    2000
  • UK/Ireland Location
    Yorkshire
  1. Charging Problem

    Sorted! Turned out to be weak cable connector at alternater. Replaced for 99p
  2. Charging Problem

    2000 1.6 Escort Finesse. Turned the key yesterday, all dials went mad & it only just started, but ran ok. This morning would not start, even with booster & batt only showing 9volts on meter. Fitted new batt & started ok, but only showing 12.74 volts charging voltage at batt, but 14 volts at alternator terminal. With evrything on, charging voltage at batt is less than 12 volts. Is this duff alty or could something be draining between alty 7 batt?
  3. Welcome to the Ford forums bunny :)