Ford Owners Club - Ford Forums Messages

Club Announcements

Ford Fair 2016: Tickets and stand passes are now available to purchase. More info here.

Review your Ford: Help others when it comes to buying a car like yours and review your Ford now

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


Bielby

Budding Enthusiast
  • Content count

    5
  • Joined

  • Last visited

About Bielby

  • Rank
    Newbie

Contact Methods

  • First Name Jake

Profile Information

  • Ford Model Fusion 2
  • Ford Year 2003
  • UK/Ireland Location Yorkshire
  • Annual Mileage 5001 to 10,000
  1. Please Help! Ford Fusion 2003

    Thanks for the responses, Think I've sorted it, small L-shaped pipe coming off the fuel pump was wet, on closer inspection it seemed the o ring inside was knackered, removed the bit of pipe and replaced with a 2nd hand part Works good as gold for now, touch wood Cheers boys
  2. Please Help! Ford Fusion 2003

    Not as of yet mate, loosing pressure somewhere along the way, It starts first time but then dies then just turns over till it eventually starts, once it's started running its alright to start up, just seems to be when it's left for long enough
  3. Please Help! Ford Fusion 2003

    Thanks for replying mate, The fuel filter is brand new mate just switched it, Going to check fuel pump tomorrow Thank you
  4. Please Help! Ford Fusion 2003

    Yeah sorry forgot to include 1.4TDCI, Thanks for replying mate and we have considered them but this morning I hand pumped the fuel into the engine using the small pump on top for a few minutes and it started, Could it be the injectors? Thanks
  5. Good morning and thanks for looking, I've had problems with starting the car the past couple weeks, It has just been turning over but not firing and getting dramatically worse, I've taken it to my mate who's a mechanic and he said it could do with a good service and also the actuator on the turbo (manual one) wasn't moving. On Sunday we changed the fuel filter, air filter and pollen filter, we sprayed a bit of break cleaner in the turbo and the actuator started moving again but not fully, it started fine Sunday and Monday but then this morning it was turning over for another 20 mins and then finally went, When I first try start it, it starts then dies within seconds then just turns over, we are going to strip the turbo and give it a good clean and change the glow plugs, also had it plugged in and no faults was on there, Anyone have any ideas? Would be greatly appreciated! Thanks very much Jake
  6. Welcome to the Ford forums Bielby :)