Ford Owners Club - Ford Forums Messages

Club Announcements

Discounted Car Insurance: Owners Club insurance could save you money on your car insurance. Get a quote

Review your Ford: Help others when it comes to buying a car like yours and review your Ford now

Ford Car Parts: View All ford car parts by category. Look for Ford Car Parts now!


skankyc

Budding Enthusiast
  • Content count

    5
  • Joined

  • Last visited

About skankyc

  • Rank
    Newbie

Contact Methods

  • First Name
    scott

Profile Information

  • Ford Model
    mk5 fiesta
  • Ford Year
    1999
  • UK/Ireland Location
    Hampshire
  • Annual Mileage
    5001 to 10,000
  1. Cheers flying clutchman that's a relief! @FOCA I have let it warm up to normal temp before and driven it for around 40 minutes on the M25 and it was the same! The temperature gauge don't really reach the halfway mark. No coolant in there at the minute as the previous person didn't bother I guess, its just been topped up with water and a bit light brown/orange looking. The car was running nice and quite a few weeks back but idle seems a tad rough, nothing major but I notice the slightest thing. Haha. But it starts/drives fine.
  2. HI, I have a mk5 fiesta, im not getting any hot air, it blows warmish for about 10 seconds then goes cold, both pipes on HCV are warm/hot, the bottom rad hose is warm, and thermostat opening, fan kicking in etc...im stuck! 2nd problem when I start the car, I can hear a little whining/rubbing noise, sounds like a pump or something, then when I press the clutch down the noise goes? any ideas?
  3. The garage looked in the expansion tank, he dipped his finger in it and he reckons there was water/oil in the coolant but I looked myself and I cant see it in the coolant. I've checked the oil filler cap and there's no creamy gunk on it. I'll have to check the thermostat and radiator
  4. I was driving for about 45 minutes, 30 mins was on the motorway. Was driving through a busy town stuck in traffic for 15 minutes, Next thing you know I felt bubbling, through the pedals, then steam was coming from drivers side of engine. Engine stalled, I restarted as the temp gauge was just below halfway, Pulled up into a carpark and coolant was leaking from the expansion bottle. I topped it back up with about a litre of water as the expansion tank was full after putting it in. Managed to drive it for 15 minutes to get to a local garage. My thought were head gasket failure, But no gunk under oil filler cap, cant see no water in the oil when I removed the dipstick. I was told it weak antifreeze, so not sure if the thermostat had rusted up due to the cold weather?? The garage I went to reckon its early stages of head gasket failure?? Any ideas on what to do next as they quoted me £300 to do it and I'm not totally convinced as of yet.
  5. I have a 1999 Ford Fiesta. In the rear center passenger seat it only has the lap seat belt I am wondering if it is possible to fit a full seat belt as I need to fit a car seat there. Thanks.
  6. Welcome to the Ford forums skankyc :)