AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


Budding Enthusiast
  • Content count

  • Joined

  • Last visited

About scousa

  • Rank
    Feet Under The Table

Contact Methods

  • First Name

Profile Information

  • Ford Model
    Fiesta Zetec S
  • Ford Year
  • UK/Ireland Location
  • Annual Mileage
    0 to 5000
  1. Sounds like a pretty good deal. I've actually got all of the parts ready to do the front end swap on my car atm except I'm waiting on new mist washers and possibly a splitter before fitting A few people have already done it without too much drama
  2. Or you could get the zunsport front grille for a similar open mouth fish look
  3. Can be done but you'll need new bonnet, bumper & headlights
  4. Yeah as far as I'm aware they have the same engine but yours is tweaked with different exhaust, air intake and engine map i believe
  5. Should have a timing belt Only thing i noticed when getting my zetec s done was a couple of garages said they wouldn't do a cambelt change on a twin cam car. Also the place i eventually took it to had to order in the locking tools to do it.
  6. Looks quality in that colour
  7. Forgot to mention car is a 2009 zetec s 3 door
  8. Hi, Has anyone had issue with the drivers seat not sliding back after being slid fully forward? Mine seems to be stuck on the out rail atm. I've already tried soakig the whole rail in wd40 but no luck so far Any ideas?
  9. Those alloys really suit this shape fiesta, i wanted a set of them or compos
  10. Ah that's not too bad then, yeah looks good fella
  11. Yeah that's a MOT fail isn't it, would look good if they were smoothed out though
  12. Why does she hate them? My missus was made up when i put better seats in my old polo cause it stopped her sliding about when cornering fast
  13. I actually think it suits the green, although I'd maybe have a green boot lid too. What's happened with your rear fogs?
  14. Now replaced the MAF sensor, air filter and coolant temperature sensor but still got the same issue. Took car to local mechanic and no errors when he scanned it and typically the issue didn't show while at the mechanics cause the engine was hot. Any ideas?